Brandon

About Orions that stop responding

Recommended Posts

Some of the first DNA Go boards can occasionally get into a state where they do not respond to button presses or USB. As of this posting, we have received reports of 180 affected devices. Approximately the first 30,000 devices produced might have it happen at some point. We’ve produced about 78,000 boards total. In the spirit of transparency, we’ve created a publicly accessible page which will automatically update from our production and service servers, so that we (and you) can track this as it goes.

https://www.evolvapor.com/info/dna-go-stats

A few key points:

Current production DNA Go devices shouldn’t be affected. If your board was made in October 2018 or later, it shouldn’t be at risk of ever exhibiting this issue.

The devices aren’t actually damaged. They’re just in a hardware reset state waiting for a signal that won’t ever come. 

We found the root cause approximately a month ago, after the first affected devices came in. The problem is in the circuitry that can read an analog microphonic pressure sensor (more expensive than the typical vaping device pressure switches), and since neither the Orion nor any of the other DNA Go based devices that we know of actually use this functionality, we just disabled it.

If you send a device showing this behavior to us, it takes about 5 minutes to make the modifications and reset it, so they’re being turned around quickly. Once repaired, your device is no longer at risk of it happening again.

So far, only about 6 per 1000 of the potentially affected devices have exhibited this problem. We expect most never will, but that number will increase somewhat  as time goes on. We’re extending Lost Vape’s 90 day warranty to 1 year for affected units for this issue only. 

If you have a device exhibiting this behavior, contact us for a repair ticket at our Helpdesk.

  • Like 8

Share this post


Link to post
Share on other sites

I've now purchased 2 from 2 different companies and both died within 72 hours. To spend this kind of money on a pod system to have them both die is ridiculous.  This is clearly a much bigger issue than just a few.

Share this post


Link to post
Share on other sites
9 minutes ago, cmcjra said:

I've now purchased 2 from 2 different companies and both died within 72 hours. To spend this kind of money on a pod system to have them both die is ridiculous.  This is clearly a much bigger issue than just a few.

Yea around 30,000 units need fixed. Theyre not Broke!! Mine is on its way back from Evolv now.. Only took lil over 1 week total to send it & receive it back.. Im in PA so its fast for me since Evolv in Ohio.  

 

Share this post


Link to post
Share on other sites

I have one that is stuck at 7 watts.  No matter what setting it's on it only goes to 7 watts. It seems like it may be stuck in replay. Would this be caused by the same issue?

Share this post


Link to post
Share on other sites
10 minutes ago, Droopydroors said:

I have one that is stuck at 7 watts.  No matter what setting it's on it only goes to 7 watts. It seems like it may be stuck in replay. Would this be caused by the same issue?

Sorry to hear that! Im sure someone can answer for u.. Im very new to Evolv & Orion my 1st Evolv device.. Good luck..

Share this post


Link to post
Share on other sites

Talked with Nick from evolv. He was amazing. I live pretty close to the company so he allowed me to just drive there with my 2 broken Orions swapped them out and gave me some new pods. 

 

While my Orion wasn't working I tried the infinix and it wasn't comparable at all. The Orion has better flavor, produces more vapor, and gives a much more consistent hit.

  • Like 1
  • Thanks 1
  • Haha 1

Share this post


Link to post
Share on other sites

Great service from Evolv. Mine stopped responding, it was bricked. I got my RMA from Evolv and in a week my Orion was back and it was better than ever. I think they changed the annoying 5 second draw time.

Awesome Customer Service, Thank you all!!!!!!!

Share this post


Link to post
Share on other sites
22 minutes ago, fish said:

Great service from Evolv. Mine stopped responding, it was bricked. I got my RMA from Evolv and in a week my Orion was back and it was better than ever. I think they changed the annoying 5 second draw time.

Awesome Customer Service, Thank you all!!!!!!!

Agreed!! 

Share this post


Link to post
Share on other sites

Unfortunately my week old Orion stopped responding, emailed a RMA request and 1/2 hour later had it....talk about customer service!!

  • Like 2

Share this post


Link to post
Share on other sites

any eta on a firmware to fix this that is user upgrade-able? I emailed the help desk and they  said "there is not a software fix for this issue yet" does that mean it is possible that an update will come out soon, just not YET? I got a 2nd orion today and if has a build date of september 11th 2018 but I dont even wanna use it outside of the house from worry it will go unresponsive when i need it. Would be great to fix it at home

  • Like 1

Share this post


Link to post
Share on other sites
On 10/29/2018 at 2:00 AM, Brandon said:

Some of the first DNA Go boards can occasionally get into a state where they do not respond to button presses or USB. As of this posting, we have received reports of 180 affected devices. Approximately the first 30,000 devices produced might have it happen at some point. We’ve produced about 78,000 boards total. In the spirit of transparency, we’ve created a publicly accessible page which will automatically update from our production and service servers, so that we (and you) can track this as it goes.

https://www.evolvapor.com/info/dna-go-stats

A few key points:

Current production DNA Go devices shouldn’t be affected. If your board was made in October 2018 or later, it shouldn’t be at risk of ever exhibiting this issue.

The devices aren’t actually damaged. They’re just in a hardware reset state waiting for a signal that won’t ever come. 

We found the root cause approximately a month ago, after the first affected devices came in. The problem is in the circuitry that can read an analog microphonic pressure sensor (more expensive than the typical vaping device pressure switches), and since neither the Orion nor any of the other DNA Go based devices that we know of actually use this functionality, we just disabled it.

If you send a device showing this behavior to us, it takes about 5 minutes to make the modifications and reset it, so they’re being turned around quickly. Once repaired, your device is no longer at risk of it happening again.

So far, only about 6 per 1000 of the potentially affected devices have exhibited this problem. We expect most never will, but that number will increase somewhat  as time goes on. We’re extending Lost Vape’s 90 day warranty to 1 year for affected units for this issue only. 

If you have a device exhibiting this behavior, contact us for a repair ticket at our Helpdesk.

I have 1 August 28 board programmed September 22 put in Mod device and another a PSO version from a month later. Both seem to be fine so far. Brandon, shoes have a worse sell-thru rate from flaws than this. GREAT JOB AND THANK YOU for advancing the options we have once again. Might you somehow make replay available to DNA250 models from late 2017. Pretty Pretty Please with Flavor of your choice on top. 

Share this post


Link to post
Share on other sites

I got this  from an on-line vendor with a purchase date of  October 31,  2 days after the posting.  It's all about the sale, isn't it.  Sucks!  My device failed on the first charge and vendor's referring me to evolve; so now I'm waiting to hear from them to have this taken care of.

This was a gift from my brother and I've told him to dispute payment to the vendor until the problem's resolved.  The postings herein are helpful in trusting optimistic expectations.  Thanks!

 

Edited by makahiapo
error in date

Share this post


Link to post
Share on other sites

I own 5 of the Orion’s, love this device. But the first two I purchased when first released died this week. First one on Thursday and second one, yesterday. I opened a trouble ticket to find out how to go about sending them in to Evolve to be repaired. Does anyone know how long Evolve takes to respond? 

Thank god I have 3 others

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, JennS said:

I own 5 of the Orion’s, love this device. But the first two I purchased when first released died this week. First one on Thursday and second one, yesterday. I opened a trouble ticket to find out how to go about sending them in to Evolve to be repaired. Does anyone know how long Evolve takes to respond? 

Thank god I have 3 others

Mine died within 1 month. But evolv is very fast!! I think they responded like 36hrs later... But dont worry they'll fix ur Device....

Share this post


Link to post
Share on other sites
On 11/16/2018 at 1:25 AM, makahiapo said:

I got this  from an on-line vendor with a purchase date of  October 31,  2 days after the posting.  It's all about the sale, isn't it.  Sucks!  My device failed on the first charge and vendor's referring me to evolve; so now I'm waiting to hear from them to have this taken care of.

This was a gift from my brother and I've told him to dispute payment to the vendor until the problem's resolved.  The postings herein are helpful in trusting optimistic expectations.  Thanks!

 

Since its a board issue Evolv is responsible.. But evolv is in u.s & only took 1 week to send & receive!! Hope all goes well for ya!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now