James

Linux EScribe Suite Beta Thread

Recommended Posts

14 hours ago, icho40 said:

Seems i was not patiently enough.  ;)

Now the installer worked despite the error-message.

I can start it.

I connected my Wismec Releaux after updating the udev-rules and reloading them.

Still get the message "Kein kompatibles DNA Gerät verbunden."

means "No compatible DNA device connected"

Check your USB cable. I've run into this a few times myself, and it's always related to a faulty cable that charges fine, but doesn't transmit data properly. If you are sure your Releaux has the DNA 200 board that would be the first thing I'd check.

  • Like 1

Share this post


Link to post
Share on other sites

Just a tip for those not familiar with installing.

I'm on a semi fresh install of Ubuntu 18.04
Download Escribe 18
Open Terminal & cd to your download Location
type chmod +x filename.run (filename being the name of the escribe file) Press enter
type ./filename.run  press enter
It will check for the packages needed and if not there will ask if you wish to install Press Y and then Enter.
it will install packages needed automatically (at least on my ubuntu Desktop install)
The command it uses is (apt-get install mono-complete gtk-sharp2)
afterwards if the installer doesn't pop up just arrow up and press enter again. IE ./filename.run

Hopefully this Helps others.  As I'm no linux pro but I do know how to look up things to do what I need.

 

Share this post


Link to post
Share on other sites

I just installed this on Zorin OS 12 without any problems once I read on how to install it.  So grateful to have this. I wanted to thank everyone who worked on making EScribe for Linux available for us.

Share this post


Link to post
Share on other sites

I've posted up SP19. This fixes a few small bugs in EScribe. It also includes early firmware for DNA 250 Color and DNA Go.

Share this post


Link to post
Share on other sites

Thanks for the update @James, just tried it out.

Curiously, this update and SP18 is very unresponsive - I've had to revert to SP17, and that works flawlessly. Did anything change recently that might help me debug?

Share this post


Link to post
Share on other sites
33 minutes ago, bluegray said:

Thanks for the update @James, just tried it out.

Curiously, this update and SP18 is very unresponsive - I've had to revert to SP17, and that works flawlessly. Did anything change recently that might help me debug?

Same issue for me on Manjaro Linix (an Arch derivative). Last update (sp18) takes forever to load and is generally unresponsive. I reverted to sp17 with much better results. I personally don't have time to debug. Hopefully, this update resolved the issue.

Edited by Odysseus

Share this post


Link to post
Share on other sites
2 minutes ago, James said:

Unresponsive in what way? Just slow? Hmm. I've switched to a new code obfuscator and a newer compiler.

Yeah, sp18 is extremely slow to launch, load and respond to input. Using the older version works flawlessly in my system.

Share this post


Link to post
Share on other sites
12 minutes ago, James said:

Unresponsive in what way? Just slow? Hmm. I've switched to a new code obfuscator and a newer compiler.

Yeah, it takes much longer to start up, and it's as if any click actions take a few seconds to complete. 

Would it be possible to try the new SP with the old compiler please?

Share this post


Link to post
Share on other sites

Can confirm 18 takes about 2 minutes to load on ubuntu. 

17 was fine. Never really tried 18 as it have been doing other things. Ie ircd web and other server related things.

Took about 30s to open about describe with no info on version. So I believe its 18 lol

My theme could have changed text as I hate white backgrounds. Due to it burns my eyes.

 

Just installed 19 and taking minutes to open also.

So something changed. Possibly the compiler and gathering everything.

Edited by D_N_D
Added update

Share this post


Link to post
Share on other sites

Arch user reporting in. This WORKS! Awesome! The only bug I find is that if I open device monitor first, then ecigstat won't find my device. Or is this expected behavior?

screenshot.jpg

Share this post


Link to post
Share on other sites

For anybody attempting to do this on a Raspberry Pi on Raspbian (Stretch), you need to install mlocate first. 

Looking at the install script, I would have thought that with this missing it would just attempt to install the dependencies anyway, and it did launch a window in which to do so but it didn't seem to do anything. No big deal, just install mlocate and, for good measure, the dependencies first, then run install script and it all works beautifully!

Thanks for the work and support on this project!

Share this post


Link to post
Share on other sites

this is my esperiencethe kubuntu 18.04 i have problem

i have install thhis afther

sudo apt update
sudo apt upgrade
sudo apt install ca-certificates-mono gtk-sharp2 libgtk2.0-0 mono-complete

and my pc portable with no monitor because is  broken and I use an external monitor  it does not come on anymore and I have the black screen this is my experience after this command and for me is not possible

Open Terminal & cd to your download Location
type chmod +x filename.run (filename being the name of the escribe file) Press enter
type ./filename.run  press enter
It will check for the packages needed and if not there will ask if you wish to install Press Y and then Enter.
it will install packages needed automatically (at least on my ubuntu Desktop install)
The command it uses is (apt-get install mono-complete gtk-sharp2)
afterwards if the installer doesn't pop up just arrow up and press enter again. IE ./filename.run
 

thanks

 

 

Share this post


Link to post
Share on other sites

I have a problem on Debian, it loads the program but after I plug the mod in and it gets to 100% it just crashes and shuts the program down.

Share this post


Link to post
Share on other sites

Hello, thanks for this piece of software. I've used it in mac and ubuntu 18 and it's worked perfect.

Now i wanted to run it on my raspberry pi and i managed to get to Escribe directly by running mono Escribe.exe

The problem is, i havent been able to enter device monitor, and whenever i try to run it, from the intro menu or from escribe, i get a "xdg-open: unexpected option '--launch'" 

I imagine theres another launcher being used in my Ubuntu installation since I have xdg-open in there and it also doesnt have a --launch option, and I don't have this launcher in my raspbian install.

Any hint will be appreciated :D

Share this post


Link to post
Share on other sites
#!/bin/bash

export UBUNTU_MENUPROXY=
mono /home/user/.local/opt/evolv/escribe-suite/main/EScribe.exe --launch DeviceMonitor &

I use this to launch Device Monitor directly.

Share this post


Link to post
Share on other sites

I want to add my thanks to the many others for the Linux version.  I was able to install it easily in Mint 19.1 Tessa.  It has worked flawlessly.

  • Like 1

Share this post


Link to post
Share on other sites

I just have to say, you all are awesome!  You can add me to your loyal fan/customer list.  The EScribe software worked perfectly out of the box (download) in Xfce4.12 under Xubuntu x86_64.  The EScribe software also alerted me to an update for the Evolv DNA Go then downloaded and applied it without any issues.  I absolutely love this device, its very well thought out.  I really appreciate all of the hard work you guys have put into this, it shows!  I'm also a Sr. Software Engineer and IoT developer in the SF bay area and understand how hard it can be to get devices to play well with everything.  I just wanted to send a heartfelt thank you for everything you are doing for the vape community and us Linux users!  +1 for Linux!

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now