Craigohm

DNA250c Ohms too low / not reading ohms

Recommended Posts

Hi,  Im new to this forum but not to vaping, (4years) so I  just purchased a Paranormal DNA250c and the first 2 days were fine with my Blotto RTA built with SS316L duel 7 wrap 2.5ID, reading .28 on ohms reader and other mods.

But now for some reason the mod won't read the ohms on the atty, I have gone into escribe and looked at (Atomiser), - no ohms and won't fire, but if i unscrew the atty a few turns the ohms pop up, 

Obviously I can't vape an atty thats wobbling around.

Please any ideas whats going on?

Cheers

 

Share this post


Link to post
Share on other sites

Yeah, I've tried my smok prince tank and kylin both of the attys  show no ohms, but work on other mods, my RDA's work though.

Ive got a quick fix at the moment of putting a heat shield I took from my Aura RDA and screwing it on the bottom of the blotto, it now reads it fine.

But im still not happy, brand new, it should be reading sub ohm tanks without the fuss.

 

Share this post


Link to post
Share on other sites

Not having things in my hand, this is only a guess.  From what you're describing I'd say the 510 on your mod is the culprit.  If you can, make sure the center pin of the 510 on the mod has some free travel and isn't sticking "down" or otherwise too far down in the connector.

  • Like 3

Share this post


Link to post
Share on other sites

Thanks for replying, Yes you are right it does seem like 510 is too low, it has a tiny bit of bounce when pushing on it with screwdriver, but it won't come up anymore.

Do i know have to perform surgery on this new mod, to see whats happening, any other people have this problem?

 

Share this post


Link to post
Share on other sites

Since you just purchased it and had it only a few days you might contact the vendor to see about getting a replacement under their warranty.  

Share this post


Link to post
Share on other sites

3 Torx screws and you get easy access to the entire 510 assembly. I think if you look/measure the length of threading on your atty's you might find one is longer than the others that could have started this issue. 

image.thumb.png.e2f3233f6ab5cb16d92d8c1372737495.png 

  • Like 2

Share this post


Link to post
Share on other sites

Thanks for help, it’s the strangest thing, I unscrewed the torque screws looked at the 510,  nothing looked bad, so I put back together, now it all works 👍 , oh well I’m not complaining. 

Cheers

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now