Craigohm

Members
  • Content Count

    4
  • Joined

  • Last visited

Community Reputation

2 Neutral

About Craigohm

  • Rank
    New Member
  1. Craigohm

    DNA250c Ohms too low / not reading ohms

    Thanks for help, it’s the strangest thing, I unscrewed the torque screws looked at the 510, nothing looked bad, so I put back together, now it all works 👍 , oh well I’m not complaining. Cheers
  2. Craigohm

    DNA250c Ohms too low / not reading ohms

    Thanks for replying, Yes you are right it does seem like 510 is too low, it has a tiny bit of bounce when pushing on it with screwdriver, but it won't come up anymore. Do i know have to perform surgery on this new mod, to see whats happening, any other people have this problem?
  3. Craigohm

    DNA250c Ohms too low / not reading ohms

    Yeah, I've tried my smok prince tank and kylin both of the attys show no ohms, but work on other mods, my RDA's work though. Ive got a quick fix at the moment of putting a heat shield I took from my Aura RDA and screwing it on the bottom of the blotto, it now reads it fine. But im still not happy, brand new, it should be reading sub ohm tanks without the fuss.
  4. Hi, Im new to this forum but not to vaping, (4years) so I just purchased a Paranormal DNA250c and the first 2 days were fine with my Blotto RTA built with SS316L duel 7 wrap 2.5ID, reading .28 on ohms reader and other mods. But now for some reason the mod won't read the ohms on the atty, I have gone into escribe and looked at (Atomiser), - no ohms and won't fire, but if i unscrew the atty a few turns the ohms pop up, Obviously I can't vape an atty thats wobbling around. Please any ideas whats going on? Cheers