Jump to content

USB Current fluctuating in battery Analyzer

Recommended Posts

I recently built a DNA250C using dual 20700s but as I run the battery analyzer the USB current keeps fluctuating up and down, without allowing the analyzer to start.

I've tried making the max voltage of the batteries 4.17v to force it to start but that hasn't done anything. Is there any ideas about why this is happening? Could I have messed up some soldering at some point?


Link to comment
Share on other sites

Your image does not show up. I've seen that before on my Mac. I usually delete that link and hit the return key once. The image should still be in the box below. By clicking the + sign in the image it should appear. 👍

Yes, it could be your soldering. I'd start down at the JST connector area (where you would have bridged those pins). 


Link to comment
Share on other sites

8 minutes ago, BillW50 said:

It looks like it is waiting to be charged to 4.20v to me. It shouldn't take more than a 15 minute wait (unless it is balancing). Here is a video of using the battery analyzer

Thats what I first thought, but I've left it like that for extended periods of time without it moving onto the next steps, the highest the analyzer has charged my batteries is about 4.17-4.18. And on that point, changing the discarge profile to a max of 4.17 wasnt doing anything to help the analyzer start.

Link to comment
Share on other sites

Well I opened up the mod and checked if any of the areas around the JST were shorted which they were not, but I reflowed some solder and it has gotten it working. In the battery analyzer it got 1 battery to 4.20 and one to 4.18 before starting to run the test, which I assume is fine.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...