Jump to content

Onboard fuse-could THAT be the problem?


Recommended Posts

Hi people.

On another forum, someone mentioned to me is could actually be the onboard fuse that is blown causing my issues, as he said he had heard of similar issues only working on USB and it was the fuse.

Thing is, I didn't have to have mine CONSTANTLY connected to USB, only when the error come up, it would go straight away, and then I could use it.

Now the Li-Po last night, the screen started to flicker, then lost power.

I went into escribe and sure enough, the battery was buggered. It would only go up to 4.89 W/h's, jump to 5.10 W/h's, then back down.


I just want to check now someone on another forum mentioned this-so could it indeed be the onboard fuse is blown, and the new Li-Po will not work? I do NOT have any Zinc flux, so soldering shouldn't work at the moment. It was actually when I swapped batteries out, soldered in the old one, without many cycles, and got the same error I was worried, but it was a 6-7 year old Li-Po.


I am thinking of completely cleaning any solder residue, and attaching the battery to the pins firmly with electrical tape-after all, repairs to mains electricty are temporarily done using this, so I see no issue with a battery.

You're help is much appreciated, and really will help me find if it IS the battery, as gearbest have sent me a new one but it can take up to a MONTH to arrive.

Seeing as at least I could use the mod before, but did not realise special solder was required, I will clean all the contacts of solder then use electrical tape to at least try to get it half working.

Thanks everyone-so Could it be the chip-or due to it stating battery error-should it 100% be the battery? It has never told me about a hardware issue, once it told me a 1.1V something, but that was using tools, to flash the firmware, upload my profile setup, test fire the atty, and then the battery.

But I gathered that was because of the battery.

Thank you-a worried DNA200 owner.

Link to comment
Share on other sites

It is not the fuse, it wouldn't fire at all if it was.

I don't know of anyone using zinc flux and I would think it would damage the board, I would stick to normal electronics solder you get from Maplins or similar.  You need to be tidy soldering the battery leads especially don't get any solder on the 3 small holes near the positive connection and don't keep the heat on for long.  I would fit a pair of XT30 connectors if you have room to save having to solder changing the battery, you can get them from StealthVape, ModMaker.co.uk and eBay.  I wouldn't use insulating tape either myself.

Link to comment
Share on other sites

Ok I tried the only other LI-Po I have-it was very weak, but it DID fire connected to USB.

So I guess it isn't the fuse-as it fired and worked, albeit at very low wattage with kanthal. 

I just have to wait up to ONE MONTH to get my battery replacement from gearbest-till then I will have to use my other 12 mods (Not DNA, but now I've tried the DNA200 they seem inferior)


So, It is almost certainly the battery, not the fuse, or anything else is it? I just like to rule everything out and make sure I am correct with my issues, otherwise they will play on my mind for the next month all day and night. 

Thanks, Conan.

Link to comment
Share on other sites

blueridgedog said:

Yea...no way is it the fuse and you can't tell with a dodgy battery if it is the issue.  If you have access to a 3s lipo in the right C range you can put on a connector and vape/test with it while you wait for the right sized pack to go in the enclosure.  



I am just going to have to wait up to a month for the replacement-a long while but I suppose thats what I get for going the cheapest route. Hopefully it will be smooth running after-plus I am going to get a second DNA200.

Whats the Hcigar one like? I have seen that for £100-in the UK. If it is a solid mod I will go for that- if not I think the efusion is my other choice. That won't be till christmas though unfortunately-unless I order on Saturday-Not sure what to do, wait till christmas, or get it tommorow night ordered, the EFusion,  Hmm decisions decisions.
Link to comment
Share on other sites

  • 2 weeks later...
blueridgedog said:

Yea...no way is it the fuse and you can't tell with a dodgy battery if it is the issue.  If you have access to a 3s lipo in the right C range you can put on a connector and vape/test with it while you wait for the right sized pack to go in the enclosure.  



I correctly set up a battery-its showing in Escribe at fully charged, all cells at 4.2Volts, balanced fine. 

The mod will only turn on connected to Escribe. Even then it will only fire at 4.5W maximum-after that it states 'Ohms too high' when they are 100% not in atomizer analyser. 

So-is it the fuse and time to RMA, or is it worth waiting? I can't send it right now anyway as I am broke for a few weeks due to christmas, I live in the UK and will have to ship to the USA. 

My family is helping me get another DNA200 next saturday ordered from the UK, so after RMA, which evolv have agreed to repair-I will have two DNA200 mods.

Thing is, I am holding out hope it ISN'T the fuse, as surely it would not fire at al would it if it was the fuse, even though it is a minimum 4.5W. 

Any idea why it is displaying Ohms too high when they are not-and only turning on connected to Escribe? 

Or is that a definite indication of the fuse? Either way, I will have to send it off in around 3 weeks for RMA if it is the fuse or another issue. 


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...