Jump to content

No response from Boxer 200


rolando
 Share

Recommended Posts

Hi All,

Firstly apologies if this is in the wrong section but seemed most suited 

I have a Boxer mod which has been working flawlessly until now :( 

All was good used the mod most of the day battery got low and i left it. When i returned put it on charge and its now showing nothing on the display and when plugged up to escribe its not seeing it either

The mod seems warm as if the battery is charging but I'm just guessing here. 

So long story short not turning on escribe not seeing it does anyone have any suggestions or what i should do 

Many thanks :)

Link to comment
Share on other sites

I think you need to return it, if it was being seen by Escribe I would say check the fuse and a pinched screen cable, but those wouldn't stop Escribe seeing it.  The heat can be caused by the charging current going going through the balance resistors next to the USB socket when the fues is blown so I guess that is part of your problem.

Link to comment
Share on other sites

VapingBad said:

I think you need to return it, if it was being seen by Escribe I would say check the fuse and a pinched screen cable, but those wouldn't stop Escribe seeing it.  The heat can be caused by the charging current going going through the balance resistors next to the USB socket when the fues is blown so I guess that is part of your problem.



Normally would the screen not light up even with a blown fuse ?
Link to comment
Share on other sites

DannyK9 said:

[QUOTE=VapingBad]I think you need to return it, if it was being seen by Escribe I would say check the fuse and a pinched screen cable, but those wouldn't stop Escribe seeing it.  The heat can be caused by the charging current going going through the balance resistors next to the USB socket when the fues is blown so I guess that is part of your problem.



Normally would the screen not light up even with a blown fuse ?[/QUOTE]
It would light up only when the USB was connected with a blown fuse, assuming the screen cable has not got damaged or come loose.
Link to comment
Share on other sites

if you have access to a multimeter you can check the voltage of the pack, and also check to see if your fuse is blown or not. also checking for burnt components. if you feel comfortable enough taking your mod apart. but the easiest way is just rma it. i doubt its your batt. that shouldnt disable the mod from being seen by escribe.

Link to comment
Share on other sites

Quick update so I've disconnected the battery and the board on its own does not get seen by the PC the fuse looks intact. Battery looks like its bulging slightly which concerns but I'm not fresh out of ideas :( so if anyone has any suggestions that would be appreciated. 

Thanks guys 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...