Jump to content

Odin 250c with doom mesh tank


jhinton7930
 Share

Recommended Posts

I caught the odin on sale and got 2 of them and was using a doom mesh tank with nexmesh 316ss coils. Love the vape I get off of it in replay, and the batteries last much longer then they did on my project sub-ohm paranormal. After about 10,000 hits or so, the replay quit working saying check connection. Fiddled with the coil for a while and kept getting the same issue. Opened up the other odin and put the tank on it, and everything worked just fine. Once again tho, after around 12,000 hits, it did the same thing. I can put it on my paranormal and it works just fine. I have hooked both odins up to escribe and reset to factory to see if it was an error that it could fix to no avail. I love the mods, but only because of how long I can wait between cotton changes due to replay. Any help with this issue would be very greatly appreciated. 

Link to comment
Share on other sites

I tried all kind of settings in escribe. Saw another post about the odin that was having similar issues. It had video links showing that it was a loose screw on the 510. I carefully took it apart and tightened the screws on the 510 up and we are back to working like it should. If it comes loose again I guess I'll have to soldier it to the 510 it's self like in the second video. Appreciate you for the response tho.

  • Like 1
Link to comment
Share on other sites

I never had a problem with my Paranormal mods either. Although others have had door problems. And some have reported if the 510 is too long of your atty, it pushes down on the 510 pin too far and it touches on the positive side on one of the battery connections. Thus sending over 6 volts to your coil until you unscrew your atty. It could damage the DNA250C board too. Although I haven't heard of any blown boards. Luckily the Odin mods are easy to take apart and easy enough to put Loctite on the threads and the Odin should outlive many of us.

Edited by BillW50
Link to comment
Share on other sites

10 hours ago, BillW50 said:

Luckily the Odin mods are easy to take apart and easy enough to put Loctite on the threads and the Odin should outlive many of us.

@BillW50 Loctite on the threads <- Don't do that. It can throw off your ohm readings. I personally encountered that AND here's a post from an Evolv employee saying the same

ThatGuySwain - https://forum.evolvapor.com/topic/69140-paranormal-75c-resistance-too-high-fix/

 

  • Like 1
Link to comment
Share on other sites

28 minutes ago, Wayneo said:

@BillW50 Loctite on the threads <- Don't do that. It can throw off your ohm readings. I personally encountered that AND here's a post from an Evolv employee saying the same

ThatGuySwain - https://forum.evolvapor.com/topic/69140-paranormal-75c-resistance-too-high-fix/

 

Yes I figured as much. That is why you move the ground wire and solder directly to the 510 base itself.

2022-01-25_151944.jpg.f4fbd18bb754f318a9ac5045eb0c3896.jpg

Edited by BillW50
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...