Recommended Posts

I just looked at a 60 board I have and can not tell you what those components are.  It looks like they removed component id's on the parts.

But in the past I have contacted Evolv and Nick quickly responded with the info I needed on missing components.

This is their help desk link. Give them a try, they have always seemed to be eager to help.

https://www.evolvapor.com/contact

Hope this helps....JT

After looking closer at your pic, you might be screwed, it looks like the mounting pad at the lower right of the 6 legged part is ripped off of the board. You might not have anything to solder to. Good luck...JT

Edited by Jetro
pic note added

Share this post


Link to post
Share on other sites
Acum 13 ore, Jetro a spus:

I just looked at a 60 board I have and can not tell you what those components are.  It looks like they removed component id's on the parts.

But in the past I have contacted Evolv and Nick quickly responded with the info I needed on missing components.

This is their help desk link. Give them a try, they have always seemed to be eager to help.

https://www.evolvapor.com/contact

Hope this helps....JT

After looking closer at your pic, you might be screwed, it looks like the mounting pad at the lower right of the 6 legged part is ripped off of the board. You might not have anything to solder to. Good luck...JT

I did sent them a message a week ago , no answer so far. I also searched all the pictures on the internet , it seems that some have marks on them , this is what I could found so far.

Thanks for the reply

IMG_20200404_165237.jpg

Share this post


Link to post
Share on other sites

I am sorry to hear that. I would try again. This time address the question to either Nick or Jacob or both they are in the service department.

Could not tell what the parts were from the picture, sorry.

Again, Good luck,

JT

Share this post


Link to post
Share on other sites
Acum 11 ore, Jetro a spus:

I am sorry to hear that. I would try again. This time address the question to either Nick or Jacob or both they are in the service department.

Could not tell what the parts were from the picture, sorry.

Again, Good luck,

JT

I have an answer from Jacob, he will send me part numbers as soon as he gets to the office, he works from hone for now due to the quarantine .

 

Share this post


Link to post
Share on other sites
8 hours ago, DyHorus said:

I have an answer from Jacob, he will send me part numbers as soon as he gets to the office, he works from hone for now due to the quarantine .

 

That is great!

Good luck with your mod!!

JT

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now