Jump to content

DNA 60 - Not reading anything on output


Recommended Posts

Trying to get my SXK 70W BB Transplanted  to DNA 60 - got the DNA 60 board - loaded profile and settings via eScribe  - connected it up to BB.

Problem : Not reading any resistance across output  - all I get is "Check  Atomizer"  - had the board out twice - double checked with 510 connector with known resistance - across the output and GND - same issue as in BB.

Plugged board with 510 soldered correctly - shows correct resistance with multi meter across pads. - connected to Escribe - no resistance in "Monitor Device" . Tried "Hard Reset" in Escibe.

If there a fuse or output breaker that can be reset ?  Tried using console to read resistence - same R=?

Do I have a duff board ?  Output "blown" ?  - any further debugging I can do ?

Link to comment
Share on other sites

Point is - with 510 connected across "OUT" and "GND" pads - multimeter shows Resistance correctly - however eScribe and board show no Resistance - "Check Atomiser".

Double and triple checked Grounding - both B- and GND pads continuity checked - board powers up - Escribe sees it - so B+ is ok . . .  Reads voltage on Battery ok . .

Opened a Ticket now . . . Hopefully the boards' not Borked !

Photos at : No resistance



Edited by melbvfr
  • Sad 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...