Jump to content

Therion 166W doesnt work on windows 10 anymore?


Recommended Posts

Hello guys,

today I tried to connect my Lost Vape Therion 166W to 2 different PCs with Windows 10 and the result seems to be the same.

At first it gets recognized, but when you try to upload any settings through escribe the device stops working.

It seems that it deletes the USB driver, so that the device stops beeing recognized.

Even tried to install the drivers again but it wont work. (Error = Unknown USB device)

Is there anyone with the same problem or is my DNA250 not good anymore?

Thanks in advance for your responses.

Anmerkung 2019-05-21 195450.png

Anmerkung 2019-05-21 195543.png

Link to comment
Share on other sites

vor 2 Stunden schrieb dwcraig1:

First thing would be to try a different cable.  External USB hubs can be a problem too.

Yes I already tried different cables and different ports.

Nothing helps... Seems that my DNA is broken.

I still can charge it through USB and vape on it, but i cant change any settings on escribe.

Link to comment
Share on other sites

  • 8 months later...
7 minutes ago, puneet_july30 said:

was there any resolution to this issue? I am on Windows 10 and have a Triade and Drone 250c and both were not being identified by escribe. I tried different USB cables and all 4 ports on my computer. 
Any help would be appreciated.

Thanks,

 

ok got a workaround - instead of using the escribe given on the first page of this forum, download it from evolve site and that would work - https://www.evolvapor.com/products/dna250color

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...