Recommended Posts

I've just received a Lostvape Orion with DNA Go chip

Question is how do I get the Go chip recognised in Escribe. I've got version 15.1 installed but it doesn't recognise it

Anyone else with a DNA Go board ?

Edited by zz99
spelling

Share this post


Link to post
Share on other sites
vor 7 Stunden schrieb zz99:

I've just received a Lostvape Orion with DNA Go chip

Question is how do I get the Go chip recognised in Escribe. I've got version 15.1 installed but it doesn't recognise it

Anyone else with a DNA Go board ?

the escribe version with dna go board support are in the moment for evolv beta test people only.it works very good, but not many setting for the new dna go board.

Share this post


Link to post
Share on other sites

Its in beta testing and only works on windows. 
You can reach out to lost vape or send a help ticket with evolv they should send you the update.

Or wait few days should be out soon given they are now shipping them to wholesalers this week should start seeing more them. 
Not many options when using it for now. 
Just change power settings and color the light for the settings so you know what power you have it set at.
I set one I use for replay on the device.
Hope that helps. 

Share this post


Link to post
Share on other sites
1 hour ago, Droopydroors said:

This is horrible. I bought the device because I wanted to use it with escribe and it does not work.... Horrible...

Not much escribe does for it. 

And think any one would rather have the feature work well vs them just throwing it up and there’s problems. The device it’s self doest really need escribe in my opinion. 

Been using one for over month and didt really need to connect it, having the option to do so was nice but no need. 

Share this post


Link to post
Share on other sites

It will be needed to lower the wattage to use nic salts.  Right now with the airflow mostly closed off and on the lowest wattage setting it's still too much power. That's why escribe is needed. That is with the .5 pod

Edited by Droopydroors

Share this post


Link to post
Share on other sites
On 9/8/2018 at 9:25 PM, Droopydroors said:

It will be needed to lower the wattage to use nic salts.  Right now with the airflow mostly closed off and on the lowest wattage setting it's still too much power. That's why escribe is needed. That is with the .5 pod

I contacted Evolvapor and tech support sent me links to download service pack for DNA Go, but they don't work.

I agree, with 0.5 pod on lowest setting, it is still too much power.

I think the boost is set too high.  Seems like coil is already burnt with just 1 tank usage.

Anybody has any luck using escribe with Lost Vape Orion?

Share this post


Link to post
Share on other sites
1 hour ago, scottyboyus said:

I contacted Evolvapor and tech support sent me links to download service pack for DNA Go, but they don't work.

I agree, with 0.5 pod on lowest setting, it is still too much power.

I think the boost is set too high.  Seems like coil is already burnt with just 1 tank usage.

Anybody has any luck using escribe with Lost Vape Orion?

They work and are now posted on these forums.  Make sure NOT to use the cord that comes with the device. It is not a data cord only a charging cord.  Also yes the .5 ohm pods are horrible mine was shot in 3 days possible because even though they say MTL they actually are not. So if you close the airflow down too much they end up burning the cotton. The .25 pods are excellent and I am on a weeks use and it still tastes great.

  • Thanks 1

Share this post


Link to post
Share on other sites

But also I have not been successful with nic salts with this device no matter what settings I use.  I use 30mg in most of my other devices and 50mg in tight mouth to lung pods.  My hope is in the future lost Vape will produce a proper MTL pod for nic salt use.

Edited by Droopydroors

Share this post


Link to post
Share on other sites
On 9/14/2018 at 9:36 PM, Droopydroors said:

But also I have not been successful with nic salts with this device no matter what settings I use.  I use 30mg in most of my other devices and 50mg in tight mouth to lung pods.  My hope is in the future lost Vape will produce a proper MTL pod for nic salt use.

Thanks for your help. I used a different cable and it connects to escribe without issues. 

I’m currently using naked 100 salt (25mg) with 0.5 pod at 6w2boost setting for MTL vape.  It performs as it should. Was very discouraged after first pod burning out within a day but after adjusting the settings, I’m happy with its performance. 

Just hope that QC of pods are in check so they last as long as they’re advertised. 

Share this post


Link to post
Share on other sites

I was really happy with the 0.5 pod initially.  I was running 25mg nic salt fully open as a direct lung vape and had zero issue.  After 870 puffs, however, the coil is now completely burnt out.  It's been 3 days, and I'm now changing the coil. 

Good thing I haven't thrown out my Mi-pod yet.  I'm going to try the 0.25 coil this afternoon and see what happens.  Hopefully it will be less prone to burning out so quickly because it will apply a lower voltage to supply the same power. 

Don't know if I'll be able to use salts however, but we'll see.  If this doesn't work, I may end up regretting my purchase, unless they seriously fix the 0.5 pods.  I don't see how the reviewers have gotten so much more out of those pods.

Share this post


Link to post
Share on other sites

I am very happy with the purchase but in my opinion this device is not a nic salt device.  If you run 3mg or 6mg freebase it shines.  Also most of the reviewers that had the device before it dropped were running regular nicotine.  Most of the nic salts on the market are, IMO, shit. They seem to be using extreme amounts of sugar to try and get flavor out of these pod systems. But really all it does is destroy coils. There are 2 things that destroy coils, nicotine and sugar.  So if you are running 25 or 50 nic salts plan on burning through the pods.  I don't think I have seen this being sold as a "nic salt" device anywhere.

Share this post


Link to post
Share on other sites

Yeah with the 0.25 coils its definitely not for salts. I would run 6mg in that one but i have seen where the 0.5 could be used with salts, which is why i purchased it in the first place. I believe i remember bogan using salts, but off the top of my head i could be mistaken. I try to stay away from sweetener, which you are absolutely right about killing coils. I like the nkd pog salts because that particular one doesnt seem to have too much sweetener overall.  My mipod and mione (which uses .5 coils instead of pods) last up to 2 weeks with that particular salt nic.  To each his own i guess, but i do wish someone with lost vape directly could clarify whether or not they intended you to be able to use salts with the 0.5 coil, but the vape i get from the salts is really good, unlike the aspire breeze 2 which the salts are entirely too strong for.

 

Share this post


Link to post
Share on other sites
1 minute ago, rstiltner0005 said:

Plus it says on the back of the pod box that its compatible with nic salts lol. 

You ain't lying!!!!  But I guess they aren't either.  But on the same note a SMOK TFV187798600 is capable of using nic salts as well. Lol

Share this post


Link to post
Share on other sites
On 9/15/2018 at 8:33 AM, Droopydroors said:

They work and are now posted on these forums.  Make sure NOT to use the cord that comes with the device. It is not a data cord only a charging cord.  Also yes the .5 ohm pods are horrible mine was shot in 3 days possible because even though they say MTL they actually are not. So if you close the airflow down too much they end up burning the cotton. The .25 pods are excellent and I am on a weeks use and it still tastes great.

 

Thanks 😁

Share this post


Link to post
Share on other sites

I know this is an older thread but just thought I'd include this here because it ends off without this info.. 

I've been using the .25 ohm pods with 50% nic salt juices daily for a few months now (and I pretty much vape it all day everyday), and the first pod lasted over 2 months before it started tasting bad and I'm about a month in on my second pod and it's still going strong. 

The only changes I made with escribe were dropping the boost down to  0  and the warmth to 1 (on all wattages) and I basically never use the replay function, after doing that I alternate vaping between the middle and highest settings (blue and red) and I seriously can't believe how long these pods have been lasting me. 

Share this post


Link to post
Share on other sites

So  anyway I know I can't say anything about how they do out of the box with nic salts and the .25 pods, but with just a little modification in escribe the .25 pods work great with salt nic for me and last longer than any other pod system or aio I've tried so far.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now