Jump to content

Got a old battery correctly balanced, showing full charge in Escribe-ohms too high.


Conanthewarrior
 Share

Recommended Posts

Hi everyone. 

I am awaiting a turnigy battery, and also ordered the correct hotcig battery from fasttech to get my Hotcig DNA 200 going. 

I managed to get one of my old Li-Pos back in balance, and first I tried my nickel profile. 0.08 single coil. 

When I tried to fire, I get the error 'Ohms too high'. I thought Hmm, lets try titanium, so switched to that profile, added a 0.15 dual coil TI build, and guess what? Ohms too high again. 

I am now worried that I have ordered these batteries to make my device work-only for it not to work. 

What on earth is causing the Ohms too high message, as they most definitely are not too high. 

I am hoping the turnigy battery turns up tommorow, I can connect it properly, and it will work, and its just due to being an old battery. It is showing that it is in balance and at full charge though-so I am really confused what could be causing this issue. 

Anyone got any idea? Is my actual DNA200 buggered? If so, I've thrown over £120 down the drain, so I really, really hope it is NOT the actual chip. It only worked for a week before the battery failed due to its severe discharge on arrival.

So, any ideas what is giving me that error? I am hoping the turniguy battery, that should arrive tomorrow, when attached and set up will sort out the issue. But the Ohms are definitely not too high, they work fine in TC mode on my other devices-and one I had not even used since my DNA200 was working, so it doesn't seem like it can be the coil. 

Please could someone help-I am learning Escribe quite easily-but am very worried that when I get the new battery, even the hotcig battery, it will not work at all.

Link to comment
Share on other sites

I have checked live ohms in atomizer analyzer and they are not going over 0.177-so are definitely NOT too high. I just pray that when the turniguy turns up and I install it-it will work fine, as the other day it DID fire with the old  battery-but for a few seconds. I think the battery is too weak, but just want clarification.

EDIT: I forgot to add, when I fire the ohms increase as they would when it fires normally-confusion is my state right now.

It can't be the fuse-I have never reversed polarity, so am at a loss to what my issue could be. I guess the only way to tell is with the new battery-although the old one was fully charged and showed 9W/h's in Escribe, with the batteries all balanced.

I HAVE accidentally arced the battery though-tomorrow I will install one wire at a time with solder, to ensure this can not happen. I will use the part of the battery from the housing that holds the positive and negative wires to the pins, so the battery Will be removable-but due to the size it will be electrical tape as housing - when the real battery turns up I can just slip it off without soldering, then connect the real battery.

Link to comment
Share on other sites

Could anybody at all help? I panic a lot due to my brain damage, so I apologize if I seem abrupt. 

Sorry to ask so much-it is just my most expensive device, and I could tell it was my best when working so I know the DNA200 works supremely-I just want to know why I am getting an ohms too high error when they are most definitely not. 

I guess tomorrow I will know when I get the turnigy whether I have a working device, or a completely broken device and have to write off £120 as a big mistake, and get myself what I can afford, the Hcigar Vtbox from the UK.

Link to comment
Share on other sites

VapingBad said:

Don't panic, just wait for the new battery and see how it is then, at worst if GearBest leave you hanging Evolv will usually sort you out.



Really? I never knew this-so if I have no luck with gearbest, which it seems it won't, or hotcig, Evolv will step in?

Also, do you have any idea why it would say ohms too high when they are not? I can't imagine the chip is damaged-I was using it at around 30 watts with two tanks, not 200W kanthal cloud chasing, I was just enjoying some gentle temp control at 230C, with a 80W preheat and 7.3 punch.

Hopefully the battery and solder turns up tomorrow-its multicore, not rosin-but that should be fine shouldn't it? I also have flux as well arriving-I doubt I will need that to make a simple connection but you never know. 

Tomorrow I will have a new tank, the crius, but the updated version with bigger post holes and a standard 510 to play with, and hopefully the turnigy battery to see if it works. 

So does anyone know what would cause it to say ohms too high, on multiple devices, and in atomiser analyzer they are definitely not too high? I hope it is battery related, and works with the turniguy until I get the actual hotcig battery delivered in a few weeks. 
Link to comment
Share on other sites

ChunkyButt200 said:

how did you arc the battery? Did you short it while it was still hooked to the board?



No, it was completely apart from the board-it was as i was soldering It to the seperate connectors from the battery housing I accidentally made contact causing the arc.

It was definitely not plugged in-I wouldn't work on it plugged into the device. 
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...