Jump to content

Am I cursed?


Recommended Posts

So, back in September I bought one of the first DNA200 (hcigar VT200) in the UK.

I was happy with that apart from the battery. So i ordered a chip and made my first ever mod!

a massive brick with a 2200 mah lipo in it!
this worked perfectly for about three weeks before it blew a fuse ....... RMA1
I bought another chip while waiting for the return, put it in and 2 weeks later blew a fuse

meantime the RMA1 arrived so I put this back into the 'brick'.  working perfectly. 
2days later the vt200 started discharging itself once it got below 20% 
and getting very warm. Sent back to the retailer for replacement!

RMA2 arrives last week and as the 'brick' is still working fine I am in no rush to make it up yet as I have ordered some battery holders and 3 lg3000mah brown to make a 3x18650 mod.

Yesterday I had some time free so made the up the triple!

Lovely build, all tested,, working perfectly, the battery analyser test was completed about 8 hours ago.

2 hours ago I went to take a puff from the 'Brick' and completely dead, nothing on the screen and no life when plugged into escribe. 

On testing the fuse is still intact, all the solder connections are good and the battery is at 11.1 the balance points measurements are 3.7 7.4 11.1 so that is all good.

so it looks like I cannot own more than one dna device at a time! as soon as I get two, one of them fails.>:(

One thing I did notice on the latest board is that it did not have the three vias next to the B+ like the earlier boards did. I wonder if evolv can confirm this as a change

Link to comment
Share on other sites

  • 3 weeks later...

Welcome to my world. I have 3 devices myself but seems like only one works at a time lol. My 3rd one the screen just went out on me. Still works just can't see anything unless I plug into Escribe, so technically I have 1.5 working devices at the moment. Good luck to you sir.

Link to comment
Share on other sites

  • 3 weeks later...

Know how u all feel lol. Bought my board in august dead on arrival. So after trying to trouble shoot it via email got a rma got it back first part of September. Worked great till October fuse blew. Board 3 got back working first part of November till the other day got the dreaded warranty service message.checked voltage of the battery and tried 2 other battery's. Love the dna 200 just hate the headache hopefully the next one is the one for my mod.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...