Jump to content

Auto fired and now not responsive


Recommended Posts

EDIT: In my haste i posted in the wrong subforum - could a mod please move me where I need to go?

Hi All,

I have a custom built DNA 200 that auto fired (ended up pulling the RDA off)
It worked fine the following day but now it is very slow to register button presses (if at all).

  • Using the device buttons I can't lock/fire/adjust watts/temperature
  • When I control it with E-Scribe it works fine (firing/adjustment)
  • The display doesnt go to sleep - stays at full brightness
  • When charging the display doesn't change to the charging screen either.
  • I have tried a soft boot and hard boot
  • The battery is soldered onto the board so I haven't tried cutting power.
  • If I have an RDA connected it will auto fire after i upload settings to device or if there's no RDA connected it will flash check atomizer 19 times.
  • No idea what wattage it fired at (set to 80 watts) however the dual Stainless Steel coil ended up melting at the screw terminals rather quickly (and thankfully stopping firing)
  • Atomizer Analyzer always reads 0.2 ohms, screen shows 0.00

Firmware version installed 2015-08-21
Link to comment
Share on other sites

  • Battery unsoldered and board removed from enclosure
  • still flashes Check Atomizer when plugged in to USB (same as observed in my first post)
  • Fire button = no change on screen
  • Up = Check Atomizer (as if it's trying to fire)
  • Down = check atomizer (as above)
  • Rolled back firmware to 2015-08-07


Link to comment
Share on other sites

  • 4 months later...
  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...