Jump to content

DNA 200 Mod Dead during firmware update


rice721
 Share

Recommended Posts

So my 2nd DX200 just bricked on me after I tried to update the firmware.

I'm running virtual box on a mac. The mod itself does not power on no matter which battery (have a 900mah and 1300mah) I connect it to, nor does it power on when connected to a computer via usb.

The mac and the win7 in virtual box still recognizes the mod as a USB device when plugged in: "ELPSCGODWTVO" not a DNA200 evolve device.

Help?

Link to comment
Share on other sites

Dude! Ive been searching everywhere for someone having this same issue, I thought I was the only one. Im in literally the same exact situation, Im also using virtualbox and I tried updating the firmware and now my dna is bricked, I looked at the usb tab in virtual box and it also reads a bunch of numbers similar to yours.

Did you happen to find a solution by any chance? This legit happened to me the day I got my box and I havent even been able to use it yet so Im desperately looking for an answer to this issue.

I really hope you figure it out!

Link to comment
Share on other sites

So for those of you having the same issue, I got it fixed. You're going to need a windows computer with escribe and force a firmware update. What happened was for some reason when you were updating your firmware in virtual box, it failed causing your device to brick. 

But if you force an update on a windows computer your device comes back to life. Hope this helps.

Link to comment
Share on other sites

  • 2 weeks later...
  • 6 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...