Legendary_Folklore

Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Legendary_Folklore

  • Rank
    New Member
  • Birthday 02/19/1977

Personal Information

  • Full Name
    Dave
  • Location
    Ohio
  • What DNA product do you own or plan to buy?
    Lost Vape Paranormal DNA75c
  1. I just picked up a LV DNA75c Paranormal mod and have it paired with a gold Druga RDA, with a dual transformer .15 ohm build @ 70w. This morning, I was attempting to use the device 4 days owning it, no problems before at this point. I came across a strange issue, when Everytime I went to fire the mod, I would get "Temperature Protection" error Everytime zi attempted to fire. Even when mod was cold. I had the mod reread the coil build and noticed it was all over the place, read it once it reported .28, then .34, the .38, back down to .21 just all over the place. I had thought that one of my leads had come off, essentially making the dual build single @ .3 ohms. After further inspection of coils, and putting mod on ohm meter, it was still a very solid .15. perplexed, I looked at the mod & noticed some juice down in 510 pin area, since I drip. I cleaned it thouroughly, as well as bottom of RDA and threads. Now, 2hrs later, I have yet to see this error. I wanted to point this out if any of you Drippers out there get any juice run down into the 510 pin area, be sure to clean it out. This might save someone the hassle like I had of trying to troubleshoot, thinking it's a much bigger problem. Have a good one, it's a frigid 14° F here in Ohio today, keep it cloudy friends!