Pjr

Members
  • Content Count

    20
  • Joined

  • Last visited

Everything posted by Pjr

  1. Hi! My Lost Vape Paranormal 75c's battery door broke off. Had it's very thin hinges loose for the past weeks then it went off totally today. Has anybody experienced this, and found a fix? Thanks!
  2. Evolv sent me a package containing the black piece for my broken batt door. Thanks Evolv!
  3. I am still waiting for my battery door. It's been over a week since Evolv sent it...
  4. @dwcraig1 Got an email from Evolv, they sent me a batt door for my Paranormal DNA 75c. Just waiting for the package, it was shipped last Friday. Most probably it will be here next week. Thanks for sending me that link. Tc!
  5. @TNT0305 How did you contact them? So happy for you. Would you be kind enough to share the email and phone number to me? So I could talk to them too, about my batt door... Thanks😊
  6. @TNT0305 Also, if you happen to know somebody, who could create a 3d file of your para batt door, you could have it 3d printed. Check 3d printing battery door on youtube.
  7. Hi! @TNT0305 I tried messaging Lost Vape, and I'm still waiting for a reply. No confirmation or anything. What I did was, removed the hinges totally and just open and close the batt door manually. I hope you get your mod's batt door replacement soon.😊
  8. Al last! I have found the best setup for my Paranormal DNA 75c. I have experimented on almost 25 atomizers from rbas, rdas, rdtas and rtas since I started vaping. I would like to share this with you guys. This has given me the most satisfying vapor and never ending flavor as I chain vape everyday. 😊 Ohms .77 upto 1.0 Interval is 5 to 10 mins every 3 to 4 hits daily I use cotton bacon v2 Just right snug not too tight not too thick Wicks should be longer so there will be no dry hits I use a kclapton 26g 32g coil and build a 3.5mm 6 loops on my single coil zeus rta. The build should be as high as possible to get an awesome flavor. I run my paranormal dna 75c at 30 to 40w My batteries are Vtc4 the best battery and with my current build this could last for the entire day and mod does not warm up or get hot at you vape. Cylaid Strong for the first 6 hours then once it hits 25% it is as good as zero power Lg choco Performance in variable mods is good and safe, however the aromizer gets warm easily and so as the mod. I highly recommend vtc4 as I use it for most of my variable setups It is as good on a series mod too judt a shorter battery life as compared to my dna 75c which is a dual parallel mod
  9. There may be a delay on the values showing on the screen. It was working okay when you press it longer, volts show up. After rewicking though, the volts change as I fire. Which never happened before.
  10. Hi! I recently purchased the new lost vape paranormal DNA 75c mod. I just had a new serpent smm single coil atty built by a local shop... while I was vaping on it, it was flavorful and produced good clouds...When I opened the atty I noticed that there were more than 5 loops probably about 8 or 10. Then I took the batteries out as I usually do when I am not using the mod. The next day I tried using the mod then I heard Poppin sound from the atty then the voltage on the screen would indicate 0.00 this is while I was trying to fire it. Now I clearly have no clue what just happened. I need your help guys...Now I am going to a different shop to have the atomizer rebuilt with kanthal at 5 loops as usual with the 3mm guide. See if the mod would behave like it used to...Because I figured that it was the only thing that was done differently on the mod before the 0 volts happen.
  11. Hi guys! I'm new to vaping and I just need some inputs and suggestions from pros like u guys.😊 Mod: paranormal DNA 75 c Atty: wasp nano rdta (single coil) Current build: dc Clapton wire 26 gauge, 7loops What's the best wattage to vape on? If I vape at 40w, volts go up to 5.45 Ohms at .6 when the coil heats up goes up a bit up to .7 Haven't found my vape's sweet spot yet. Scared of ramping up the wattage, because the voltage goes high too. 😊 I also get spitbacks at 35-40w sometimes. Build was done yesterday at the local shop.
  12. Hi, i'm new to DNA. I have dna 75c paranormal and hcigar vt75 nano dna. Got 2 attys built in dc clapton wires 26g 7 loops on smm rta and 7 loops wasp nano rdta both have single coiled atty. I noticed my mod's resistance from.66 jumps to .71 everytime I vape it. I tried using both attys on the hcigar, there it's worse. The jump goes from .60 down to .4 and other numbers. With the paranormal, from .66 to .71 every hit. Your answers will be much appreciated. Cheers! Poj
  13. Pjr

    Preheat in Kanthal - It Works!

    Hi, i'm new to DNA. I have dna 75c paranormal and hcigar vt75 nano dna. Got 2 attys built in dc clapton wires 26g 7 loops on smm rta and 7 loops on wasp nano rdta both are single coiled atty. I noticed my mod's resistance from.66 jumps to .71 everytime I vape it. I tried using both attys on the hcigar, there it's worse. The jump goes from .60 down to .4 and other numbers. With the paranormal, from .66 to .71 every hit. I only vape at 40watts on both mods. Your answers will be much appreciated. Cheers! Poj
  14. Hi! Nobbi, I have the same mod and the resistance jumps from .66-.71 when firing. I just noticed it. Will take my mod to a local vape shop to get it fixed.
  15. Pjr

    USB Connection

    Thanks Giz for the prompt response. I'll try to configure it on escribe then. I'm getting the "temp protected" error message too on a newly built wasp nano rdta (ss wire 28 gauge) it seems that the only wire it is able to recognize was kanthal 0.4 or 0.5 If the loops were more than five that's when it started to display the temp protected error message and the 0.00 volts sometimes.
  16. Pjr

    check atomizer message after SP23

    Hi! My paranormal mod displays 0.00 volts while firing. Then it will display the correct voltage after awhile it goes back to zero volts but it's firing. This is scary. Anyone having the same issue?
  17. Pjr

    Lost Vape Paranormal DNA 75c

    Hi My paranormal mod displays 0.00 volts while firing. I just had it for 2 weeks. Anyone here who had the same issue? Is there a fix for this? Because it's quite alarming since it concerns voltage on the mod.
  18. I tried using a different atomizer on the paranormal mod. It fires alright but still a bit of a delay sometimes on the screen displaying 0.00 volts. Could be the firmware that needs an update.