Jump to content

Weird battery issues with DNA250C


Recommended Posts

Hi

So I have a Paranormal and Centarus DNA 250 C, I am getting weird battery readings like 19% while its full and i am using the correct battery curve csv. Batteries work fine on other mods and i tried 3 different sets. When i am looking at Escribe i see this. both batteries read way below the 4.2 and they are both freshly charged, one of them keep on dropping to 2. something and then back up to 3.4, any idea what is going on?

Screenshot 2021-11-19 204335.png

Link to comment
Share on other sites

Are you firing to make those spikes? Or is this from just sitting there?

There is a tiny pin when you open the battery door that springs up and down. Make sure it isn't stuck down. Then I would clean the battery contacts with alcohol and make sure it is dry and try it again. I don't have much hope that will take care of it. But it is the first thing to do.

Link to comment
Share on other sites

36 minutes ago, BillW50 said:

Are you firing to make those spikes? Or is this from just sitting there?

There is a tiny pin when you open the battery door that springs up and down. Make sure it isn't stuck down. Then I would clean the battery contacts with alcohol and make sure it is dry and try it again. I don't have much hope that will take care of it. But it is the first thing to do.

Not at all, its idle and everything is cleaned already. multiple sets of batteries show same behavior

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...