Jump to content

DNA250c bricked after firmware update?

Recommended Posts

I've had this device for about a month now.  When I got it, I did not update the firmware - I just saved the default theme and settings, and then transferred over my own theme and settings that I have been using on a different device.  All was fine, except I noticed that when it had been idle for about 30 minutes or so, the first time I would go to fire the device there would be a few second delay on the first fire.  So, I thought maybe it was a firmware issue that would be fixed with an update.  So I connected to my escribe, downloaded settings to the software and clicked the button to update firmware.  It did it's thing and loaded everything like normal, but now my device will not turn on at all.  Also, when I connect the escribe I get this error, "The firmware is still starting. It may take a moment."

I have taken out the batteries and let it rest for a few minutes.  I have removed the RDA.  I have tried the 5 clicks on the fire button.  Still will not turn on.
Also, I have tried connecting my other device to escribe and it connects just fine.

Have a just bricked my device? I'm so upset right now, I really need help.  Please anybody.  Thank you in advanced!

Link to comment
Share on other sites

It says, "A Service Pack is about to be applied.  Before clicking OK, please make sure that the device is idle."

When I click OK, I am to select a file.  I can go to "DNA 250 Color" and there are 3 files to choose from:

When I select one, it appears to apply the service pack and says, "Service Pack applied."

Oh my god it works now!  Holy .... you just made my day!  Thank you!!!!

Link to comment
Share on other sites

The problem seems to be the firmware update.  In the above steps I applied SP35, which fixed the issue but gave me the error press up bug.  But when I try to update to SP38, it happens again - device appears off, wont fire, ...etc.  I have reapplied SP33 and it seems fine now.  I'm not sure why this is the case, as my other DNA device is using SP38 with no problems, but I guess it is what it is, just glad to have both working again.

Thank you again @retird for your help, you are an escribe GOD!

Edited by str8.drippin
added more information.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...