k3kz3

Lost Vape Paranormal Evolv DNA 250 Color Battery Problem

Recommended Posts

Hello Guys,

 

i've searched the whole day yesterday on the internet about anyone who have the same Problem...

got my new EVOLV DNA 250 Color (Lost Vape Paranormal) and bought 2 new 18650 Batterys for it to use it with my top coiler.

The Problem is, the battery is charging very very slow in that mod. but the bigger problem i got is the lifetime!!! i can only use it (on 70W with dual coil on 0,25ohms only for 2-3 hours if i use it often.

the same Batterys in my Crown 4 with the same Deck have an lifetime over 6 hours or more...

i used the battery analysis this night to make a profile for these batteries. but nothing really changed :/

 

anyone knows why my lifetime is so bad in this Mod? is that normal for an 200€ Mod? 

 

Thanks for your help! :)
I really love all the functions on escribe and the design... i don't want to give it back and change it to anotherone :(

 

 

Share this post


Link to post
Share on other sites
9 hours ago, k3kz3 said:

Hello Guys,

 

i've searched the whole day yesterday on the internet about anyone who have the same Problem...

got my new EVOLV DNA 250 Color (Lost Vape Paranormal) and bought 2 new 18650 Batterys for it to use it with my top coiler.

The Problem is, the battery is charging very very slow in that mod. but the bigger problem i got is the lifetime!!! i can only use it (on 70W with dual coil on 0,25ohms only for 2-3 hours if i use it often.

the same Batterys in my Crown 4 with the same Deck have an lifetime over 6 hours or more...

i used the battery analysis this night to make a profile for these batteries. but nothing really changed 😕

 

anyone knows why my lifetime is so bad in this Mod? is that normal for an 200€ Mod? 

 

Thanks for your help! :)
I really love all the functions on escribe and the design... i don't want to give it back and change it to anotherone :(

 

 

i wouldnt advise charging the batteries via the mod for safety reason and life span ,( although plenty do) its always recommended to have a stand alone charger  , i hope youre using the usb cable that came with the device and not a mobile phone charge or anything of that nature as sometimes the amperage is different to what the device  needs and then there is the right type of batteries yes you can use any 18650 but better the amperage , better the mah and that results in how long the batteries last and how often and how quick they charge and buying from a trusted source theres alot of fake batteries out there - any device like the DNA 250C would require Samsung 30Q batteries with something like 30 amp discharge and 3000mah or anything equivalent to those figures 

 

Edited by formula 1

Share this post


Link to post
Share on other sites

thak you for your answer :)

i use the LG Brown ones 3000 MaH 3,7V 25amp Max:35amp
the thing is... on my crown 4 the battery isnt fast empty as there.

i got 95%

i press 2-3 times the fire button for 3-5 Seconds and then i got 89%.

sometimes even lower...

 

that can't be true... i use my ecig for travelling. can not use it if the batteries are so fast empty :/ can it be it is an option in escribe to optimize it? or is it a hardware defect? or is it simply such a powersucker? :D

Share this post


Link to post
Share on other sites
1 hour ago, k3kz3 said:

i would start by buying a standalone charger and if you get the same results i would buy another pair of batteries and compare the two , it may well be the battery isnt getting enough charge or you may have a faulty set or even fake pair of batteries , if you get the exact same batteries and they charge or perform better using the stand alone charger then i would return the other batteries to the vendor you bought them off , then we can rule out one thing at a time

Share this post


Link to post
Share on other sites

plus i forgot to mention you can monitor the battery to see how many amps it pulls when firing either through the theme you use or in escribe in every time you fire it

Share this post


Link to post
Share on other sites

Instead of using battery percentage which may not have much accuracy to it take a look at cell voltage using EScribes device monitor both firing and standing voltages.

Share this post


Link to post
Share on other sites

I had exactly the same issue with my Paranormal. Sony and Samsung batteries, and this mod simply fails to charge it completely, which I personally think is a shame, since my Vaporesso Revenger X always did this work well until it died. Solved the problem buying a proper charger, but in a trip to not be able to charge my batteries with the mod will be a problem, since the charger would be another big volume on my bag. But... That's the way it is...

Cheers

Edited by vimagreg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now