now Stopped Firing DNA 75

Recommended Posts

I'm hoping someone can help with this issue,

The Therion DNA75 has stopped firing,

I have tested the Tank on another mod and all is well, but what I am getting is that the Display shows as normal, I press the Fire button, it says firing for about .5 second then switches to new coil, and suggests an option between new coil or not and says .28 ohms when read (not far off )

it does not matter is i choose yes or no, it will not fire, it goes blank screen then switches to standby mode, I have updated the service pack, returned to stock theme, checked as many settings as i can in light scribe and can't see anything wrong.

any advice please ?



Share this post

Link to post
Share on other sites

Hi Martia

Did you try another Atomizer on that device ? Did it work on it before ? I heared about some Atomizers that don't work sometimes on specific devices but work fine on others.

Mabe bad connection on the 510 pin, some devices like a longer pin depending on the depth of the hole... if it is an adjustable pin maybe try screwing it a little more further out to get a better contact.

Share this post

Link to post
Share on other sites

Hi, yes I'm using The flave tank, for 2 months without issue, it works still on the geek vape squonker and I tried 4 different tanks with full range of coils from. 2ohms up to 1.5ohms 

It won't fire on any, I tried thoroughly cleaning 510 no evidence of juice anywhere to be honest it has never leaked, I fill using a 510 coil master for a clean fill. Can't weigh it up.... 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now