Jump to content

Another DNA200 failure- 5 out of 5.


Recommended Posts

Hi everyone, two days ago my Efusion gave up the ghost, and today I was using my Hotcig DX200 converted to dual 18650's (both of my hotcigs had board replacements from evolv). 

It was running fine, but then displayed a 'shorted' message, and the battery meter went from full to empty. Now when I attempt to fire, it just displays shorted. I've tried a reset in Escribe, the RDA works on my DNA75 and other mods, so I am unsure what is going on. 

If it is another failure, I will have to leave Evolv behind which is a shame, as I really like them when they work. I think you can understand my frustrations though and if you had 5 devices fail that used the same boards would feel the same. 

Any ideas what I can do to fix the mod? I hope it doesn't need sending away as I live in the UK, if it does I will just count my losses and move on.

 

EDIT: I removed the 18650 section, and bent the pins as I remembered these could lose contact. It seems to be working now- for how long I am unsure. 

Edited by Conanthewarrior
Link to comment
Share on other sites

Thank you @retird. My memory isn't too good (brain damaged), but I recalled the pins in the back of the hotcig sometimes needed moving to get a good connection. I bent them downwards gently. 

I think this may have happened the other day when I noticed my Li-Po powered hotcig was not working. I swapped the Li-Po for the Li-ion pack to see if it was the battery, and it was. 

Now I just need to find a new enclosure for the battery. I tried to solder one in before, but messed it up. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...