TorturedZen

I know this isn't right...Therion 166 TC issues!

6 posts in this topic

All my builds are SS316L using a TCR of 92. Average ohms between 0.15 to 0.20. Coils are always cold/room temp. I usually set temps around 400-420, 60-70 watts no preheat. First couple of hits are excellent. Then TC kicks in, cuts the wattage and compromises my vape. No matter which atty I use or what build, it still hits TC way too soon. Tried lowering wattage, raising temp thresholds... same thing.

So now, when my Therion hits TC I'll remove the atty then quickly put it back on. It detects new resistance since the atty is still hot (usually only a 0.01-0.02 difference) asks if it's a new coil, so I tell it YES. (hope this is making sense so far). I then lock the new ohms detected and the vape goes back to normal, without TC kicking in.

I understand you shouldn't have to lock ohms unless the atty is wonky but all mine are solid and I've always double checked for loose leads etc. So what the hell am I doing wrong? Or not doing? And please don't say SS316L is a crap shoot. It works fine on other devices.

Thank!

Edited by TorturedZen

Share this post


Link to post
Share on other sites

At only .01 - .02 rise in resistance from a cold coil to hot, it would seem that you are not getting enough of a rise in resistance. If the board doesn't see enough rise in resistance in the first second or so, it will drop out of TC. For instance, my current SS316L coil is .178 cold & rises to .210 - .211 after firing. Have you tried spacing your coils? What kind of atty? Can you post a screen shot of Device Monitor while firing, with the following fields checked...Power, Power Set, Temperature, Temperature Set, Cold Ohms & Live Ohms...

 

Capture.JPG

Edited by giz_60

Share this post


Link to post
Share on other sites

Correction on those numbers. I meant to type 0.1 - 0.2 

My apologies...I was tired when I posted last night. I'll get a screen shot up here later today.

 

Share this post


Link to post
Share on other sites

Here's my screenshot. Atty is Augvape Boreas V2, spaced SS 316L dual fused claptons...

 

Therion device monitor.jpg

Share this post


Link to post
Share on other sites

My guess on this is the wick isn't keeping up with the coil, you might try dripping a bit of juice through the drip tip /top to prove/disprove this.

Share this post


Link to post
Share on other sites

This isn't SS316 but here is a screen with 120 watts for 0.5 seconds preheat and 45 watts after. No air, just holding the fire button down.

KF5.2.PNG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now