Jump to content

Triade DNA200 fried?


Apexifd
 Share

Recommended Posts

welcome apexifd. does the mod still connect to escribe? if not then start sending out the emails. if it does, could you post a screenshot of device monitor with all of the battery options checked. now, if you know for a fact the board is fried, contact your vendor first wait to see what they say. if they won't help, explain your situation in a help ticket from evolv.

Link to comment
Share on other sites

Jimmeh said:

Your batteries aren't fully charged. your cells are unbalanced and cell 3 looks likes it's done for. You need to replace all three batteries and keep them married and charged with an external charger. 

Already tried different set battery.. Nothing. Both set of battery works fine with my reuleaux dna200. It's the mod causing the issue for sure.
Link to comment
Share on other sites

BillW50 said:

Whenever I have seen one cell read low and it really isn't, it's is the board. And I have also seen the one reading low, the DNA200 will be draining that cell as well. So I would pull out the 18650s.

Won't even be able to use this mod right now. It will turn itself off as soon as I thread on a atomizer.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...