Jump to content

Tugboat DNA 200 USB Dead


Recommended Posts

hi everyone,
i was charging my mod with an 0,50 Amp max wall adapter and the same USB cable i use to connect to escribe, after leaving it there for 1 hour, i reached it to look at what % of charge it had reached and i noticed that it was recharging the mod at 0.18 amp.
Since it looked strange (it usually charges at 0.49-0.50 amps) i've unplugged everything and tried to connected to the computer where i've found out that i was no more read by the computer.
i've tried to reboot and reset everything on the computer, change the usb cable but nothing worked, so i thought i might recharge completely the battery via ac wall adapter but this time i could not even charge it on the wall adapter.
i've tried three different cables and four or five different wall adapters
now i'm stuck like that..any advices?

Link to comment
Share on other sites

If the cells are out of balance and one is almost full it would have to slow, also if the board temp is high it would slow the charge, not sure of the temp limit I think around 125 F, maybe a bit more.  You can see the cell voltages in Device Monitor and put the board temp on the charge screen to check if it is either of these reasons.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...