Jump to content

Escribe will not connect to any of my mods.

Recommended Posts

I have the latest Escribe downloaded and installed, but I have tried every one of my mods and none of them will connect to Escribe. I have used several different ubs ports, several different usb cables, and nothing seems to work. I think there has to be a driver or something that I'm missing. Please help.


Link to comment
Share on other sites

Have you ever used escribe on this PC before?
What mod?
OS version?
Just what Service Pack did you download?

I'm a Mac guy, but these are usual steps taken
Reboot PC. Use a known data cable (like for your phone), if you can plug directly into PC (not a hub). 

Link to comment
Share on other sites

A long time ago I did use Escribe on this computer, but never really dived into it. I've tried my SQEVO, Pulse V3, and many other mods and the software does not see that they are connected. I'm using windows 10. I downloaded Escribe from the Elvolv site, the windows english version

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...