Jump to content

DNA75C LED


cr0000ss
 Share

Recommended Posts

Nice to meet you, everyone.  When I assembled the DNA75C for the first time this time, the LED lights up like this and the power does not turn on.  What does this mean?  I've investigated various things, but I'm in trouble because there is no similar phenomenon.  I am sorry for the difficult-to-read sentences because I am writing through translation.

775FFDBD-E2F9-4B06-9875-8E8A88406EAF.jpeg

C53F6CD7-C4EA-4542-A87E-27C7F25B0374.jpeg

Link to comment
Share on other sites

Translation: I'm sorry, I'll enter it in Japanese.
No matter how many times I check how to insert it without displaying the screen, it does not appear.

 

I still do not understand what you mean, so I will ramble. 
The DNA75C datasheet shows how to install the screen. https://downloads.evolvapor.com/dna75color.pdf
When the ribbon cable is bent over the LED it will still shine through, showing a color, if you choose to.
Some mods have a dedicated hole where you can see it. Some mods have a big enough gap around the fire button where you can see it. Some mods use a clear fire button. Some mods you can't see it at all.

I hope that helps.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...