Jump to content

Dovpo Riva Dna250c Replay not working

Recommended Posts

Yes, I've ran it on the Dovpo Odin mini Dna75c. The first thing I did when it stopped working was grab another tank with a 316 coil. 


It's not necessarily that it makes sense but between work all day, stuff going on at home, and I have three reviews to write, I am just exhausted trying to get it to work. I very much appreciate you trying to help me and if I can ever return the favor then just let me know.

Link to comment
Share on other sites

I was ready to give up and was checking emails and saw that I got a response from Jacob on the Evolv help desk that I somehow missed yesterday. He suggested the following and it actually worked. I was ready to send the unit back as defective. I just wanted to let you know so if you run into this again. Once again, thank you so much for all of your effort trying to help me. This is what Jacob had me do.

"Connect the Device to Escribe and go to Options>User Interface> Manufacturer

Then go to the mod tab, then safety.

Under the option Replay, switch this from Restrict to viable coils to Allow dubious coils."



Link to comment
Share on other sites

I don't really know why that setting needed to be changed when it worked before like it was but I'm very happy that it's working now. I use the same 316ss flat braided coilology coils in all of my original Zeus rtas.

  • Like 1
Link to comment
Share on other sites

Short answer.
It works, who cares. It was that second checkmark and 'allow dubious'. 😀

Much longer answer.
That 'puff saved, playing' checkbox should only have a checkmark in it, while you're successfully in 'Replay'
I was very surprised earlier when you were getting a good puff at 35 watts (probably your preheat watts) in TC mode at 199°F. Water doesn't even boil till 212°F. VG > 350°F. So you should not have been getting any vapor.
BUT by that simple change of the material to SS316 from 'watts', it complicated matters, heaps. So you were in a Temp protected/Replay hybrid mode. 
It's much easier to diagnose each mode/function singularly (TC mode or Replay in 'watts')
I was even more surprised it worked on your 75C
We have a whole area for Replay and Atomizers. Some require that option. I don't know if it is due to your wire or your atty.


Dubious Mode is not even an option on the 75C's, and I rarely if ever go there. Here's a much better explanation from James.


But hey, it works. 👍

  • Like 1
Link to comment
Share on other sites

Thanks for the explanation. I'm glad to learn as much as I can about this stuff. I know I'm late to the game on dna. I think it was last year that I bought my first dna which was a Jac.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...