Jump to content

Orion DNA GO : Blinking Purple and not firing


Recommended Posts

I bought an Orion plus at on the 12th of September 2020
When I try to fire it, it blinks purple...
Here's a video of that (strange) behaviour : https://youtu.be/VArwvXgcy18
I can connect the ecig with Escribe and I got these infos : 
Serial Number: **** **** **** (I removed it)
Firmware Version: 1.1 SP39 INT
Revision Code: 311103968
USB Vendor ID: 268B
USB Product ID: 0417
USB Product Version: 3.0
Tried with another pod, also another coil and it's still not working.
May I get your help please ? 
Link to comment
Share on other sites

And....try this

Follow these steps:

Plug device into Escribe and open Device Monitor (no atty attached)

Lower left corner (LLC in later instructions) should say Normal or Charging. If it also says Locked then click the fire button 5 times.

 Press fire button once.  Voltage drops. No atomizer message in lower center of Device Monitor.

 Press and hold adjust button for a second or 2.  No Atomizer should appear to the right of Mode in LLC (toward the center of the line, not close to Mode section). Adjust message seen in the Button: category. (lower section of Device Monitor).

 Press fire button 5 times.  Mode should show Locked (in either Normal or Charge Mode.

 Press fire button and voltage should drop.

 Press adjust button and where it says Buttons it should say “Adjust”

 Press adjust button 6 times… may say “adjust” or “none” beside Button… no change in voltage while clicking 6 times.

 What are your results compared to this description?

If you don't get these results do a HARD RESET of the device and repeat the previous post again.  What are the results?  TOOLS/DIAGNOSTICS/REBOOT DEVICE/HARD REBOOT

  • Like 1
Link to comment
Share on other sites

  • 1 month later...

I've got the same problem with a one year old unit, on and off, seemingly at random. Sometimes it just doesn't fire, no atomizer message appears on device monitor. I did all the steps of the previous post, and again after a hard reset, I'm not sure what I'm supposed to get from this.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...