TJ89

HELP DNA75C wont start with battery

Recommended Posts

Hi Guys,

my Vicious Ant Club Omega makes me problems and i didnt find any help in other groups.

From one day to another it didnt worked...

i connected it to to Escribe and my Volt settings jump from 4,2V to 3,7V

The only difference is if i remove the battery and the atomizer i can acess the mod settings without getting kicked after the 5 clicks to unlock.

If i have the battery or the atomizer connected it shuts down after the 5 click unlock.

Any clue or advise how i can fix this?

 

Thanks Guys :)

DNA75c Vicious Ant with battery and atomizer.PNG

DNA75c Vicious Ant with atomizer but without battery.PNG

DNA75c Vicious Ant without atomizer without battery.PNG

Share this post


Link to post
Share on other sites

mhhh didnt uploaded  probably

first pic is with battery and atomizer  

second pic is  with atomizer and but without battery

third pic is without battery and atomizer

image.png

Share this post


Link to post
Share on other sites

Most likely they will let you send the whole mod. I have a Va Spade DNA75C 21700, looking at it I can't see how to get it apart.

Share this post


Link to post
Share on other sites
vor 20 Minuten schrieb dwcraig1:

Most likely they will let you send the whole mod. I have a Va Spade DNA75C 21700, looking at it I can't see how to get it apart.

yeah same i also dont know how to get it apart...

in the ticket they told me my battery doesnt have contact, but i cleaned the contacts and also from the pure looks it has contact

Share this post


Link to post
Share on other sites

I went and looked at a review of your mod. It appears to have the same battery cap as mine. On mine the threads on the cap and the threads in the mod need cleaned quite often. Have you done that? 

Alcohol works good.

Also maybe try a different battery if you haven't already.

Share this post


Link to post
Share on other sites

i did it with water but will try it again with alcohol thanks for the tip.

In the ticket they tell me to contact VA but this isnt an option as i live in germany and shipping plus sending it back is really expensive...

hope the alcohol works

 

thanks 

Share this post


Link to post
Share on other sites

So I hooked up my DNA75 VA Spade to Escribe and started loosening the battery cap, here is the result in Device Monitor. 

This is what a bad connection between board and battery looks like. In this case the bad connection was between the battery and battery cap. But there are other places that could be problematic. Very possibly the 3 screws that hold the board to the case provide the ground for both the board and 510. Or a bad solder joint on the positive lead or contact.

As I said I couldn't figure how to take mine apart, I wanted to see how they did the B- on the board. They could have used a wire to a stud in the case, I don't know.

loose battery cap.JPG

Share this post


Link to post
Share on other sites

Well looks like the connection on the plus side is damaged as I cleaned it and it’s also tightened and has connection but still it didn’t work...

Share this post


Link to post
Share on other sites

I have always wanted to see how VA wired it. I tried to remove the cover over the board but gave up. The cover is just press fitted in the case. I fashioned a tool from an o-ring pick and got the hooked end inside the little opening and pulled, the cover came right out. 

Note the black wire, it goes from B- to a spot on the case right under the board. How they attached it I'm not sure, that's copper to aluminum so maybe they glued it.(?)

The 3 screws holding the board into the case are able to provide the necessary ground for both the board and 510 socket.

All 3 screws on mine were a little on the loose side.

I would guess that your problem is with the ground and not the positive.

 

Make tool.JPG

Notch by barrey cap.JPG

Using tool.JPG

Black wire.JPG

  • Thanks 1

Share this post


Link to post
Share on other sites

Holy thanks for your work and help !

awesome!

problem now is mine looks a little bit different and I don’t know where I could open it as I don’t see a little ledge or anything

233BF16C-8D87-48FC-867A-E0A52325E9F7.jpeg

Share this post


Link to post
Share on other sites

Well then the only thing I can say is that end of the cover needs to come out first. The cover is not glued, well at least not on mine, it is just pressed in tightly.

I was able to get my finger nail into the center and ran the edge of a credit card down to the bottom but the card wasn't strong enough to pry it out.

Care must be taken  to not hit the components on the board as they could get knocked off.

 

va.jpeg

Share this post


Link to post
Share on other sites

You just pushed it out from the bottom right?

i got a little room now on the bottom and with raw strength I could pop it out I guess but I’m a little bit afraid to damage it completely 

Share this post


Link to post
Share on other sites

Well it's nice to have the cover but if you break the cover it won't matter much. Just make sure that you only have a hold of the cover.

Share this post


Link to post
Share on other sites

Soooo I opened mine and the screws are tight but still the same problems.

is there anything that you see in the picture that could be the problem?

0921CDC1-A5BD-4072-B259-D90EB009235A.jpeg

Share this post


Link to post
Share on other sites

I was really hoping that was going to fix it. No I don't see anything. Try to get back with  Evolv, I would expect they will let you send the mod in for board replacement or repair. If they do they will pay return shipping. They generally get the work out the same day it arrives.

Refer to these posts.

Share this post


Link to post
Share on other sites

Yeah tried 4 different fully charged vtc5a who work in other mods.

guess I need to buy a new one than 😕

 

thanks for your help :)

Share this post


Link to post
Share on other sites

Did you buy it directly from the Philippines? VA only services the ones they sell. If bought from a vape shop you have to go through them. You need to pursue Evolv, it's the best way.

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now