Weenuf

Evolv DNA 250 Issues

Recommended Posts

Good afternoon, please first off accept my apologies, it is my first time in an online forum since I was twelve and I am not sure how to go about this?

 

My partner is having some trouble with his "Evolv DNA 250" as per the title.

I've downloaded escribe and it seems the Mod is still alive, it is currently in normal mode but the display is not showing anything at all.

I have tried to come out of "Stealth mode" in case this is the issue, and tried using it as a right handed config as welll but neither have any result. The only function I can get the mod to perform is to lock and unlock. Putting an Atty on top has not helped either.

I have also tried downloading the new update that was in the top of the Evolv programme but no change there.

I've attached the Evolv Device Monitor screen - hoping it will assist you lovely folks in helping me :)

Please can someone give me some simple to follow advice (I'm unfortunately very new to all aspects).

 

Many thanks,

Weenuf

evolv.png

Share this post


Link to post
Share on other sites

Is that mod actually a regular black and white screen with 3 batteries, or an internal Lipo battery?

You posted in the 'color' section, but I can move it if necessary.

For starters the cells look low, too low to work, but when you plugged in the cable, did the screen light up?

If you look at the very bottom line where it says Mode: Normal, over to the right it will show/detect button presses. Over and on the left it shows the watts set at at 80.30, so if you press the up/down button, that value should increment/decrement 

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi Wayneo, thanks for the response.

It is a triangle shaped mod with just black and white display, triple battery, so maybe this thread should move?

I will look at ordering some new batteries - regards to plugging in the cable no, no screen display came on.

When I push any buttons nothing really happens other than lock and unlock can't change the wattage.

Thank you for your time :)

Share this post


Link to post
Share on other sites

Buying from a reputable supplier for those batteries is best. Here's a Mooch link for batteries and suppliers. https://bit.ly/3busyvf

Had it been sitting for a while, or did something happen just prior to it just no longer working?

Welcome :hand_splayed:

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi again, on the battery note.. tried another set.. And now it's fully alive! So thanks for bringing that up as now have a working mod (: 

It was sitting for a while so maybe the batteries gave up.

Thread can close / disappear now and thanks again Wayneo

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now