banished dj

dna 75 problem, please help me

Recommended Posts

I just received the DNA75. I have a problem both with single or dual battery 18650: when I turn the board on, it shut down immeditely. When I connect it with escribe the display show battery 0%, V 0, ohm 0, a 0. Do you know if the problem is the software of firmware? Do you have the link of the right sofware and firmare do I need to use with MAC? Thanks!

Share this post


Link to post
Share on other sites

Not enough info from you to determine the issue....  did you build the mod?  The default firmware and software should be OK.

Best guess is short circuit or bad grounding.   More info would help....

Share this post


Link to post
Share on other sites

No, when I push the fire button the screen shows “evolve75” and than it shuts down. If I keep pushed the fire button the screen flash and shows “check battery” than it shuts down. I also tried with a vergin 21700 battery and it’s the same. 

Share this post


Link to post
Share on other sites

My best guess is that it is either a bad circuit board or excessive heat while soldering battery wires (negative connection) to the board may have damaged it.  From your picture it looks like the area around the negative solder point is discolored like it got very hot.  

At any rate just start a ticket with Evolv and explain it to them and provide the pictures... they will guide you...

https://helpdesk.evolvapor.com/index.php?a=add&category=1

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now