Jump to content

Neo Go, does not exceed 10 watts of power


Recommended Posts

Hi all,I bought the Neo Go dna a few days ago, and I am using new 18350 KEEPPOWER 1,200 mAh 10 amp batteries, despite the low resistances, in the order of 0.25-0.40 ohms, and despite the power set at 12-14-16- 18 watts, in escribe I do not exceed 10 watts of power, I even see that the volts also drop to 1.80. All this with new batteries have a week of life and 100% charge. I tried to change atomizer and various wire thicknesses, I am using a 26 awg, SS316, but also with SS316 28 awg it is the same thing.Yesterday everything was fine, I was also up to 20 watts today without any reason with 6 different batteries all new and all 10 amps I don't get more than 10 watts of power. what happens? who can help me?Thanks




Edited by Pino74
Link to comment
Share on other sites

In Device Monitor check the box for (battery) voltage. While firing note what the voltage drops down to. If dropping below 3.1 volts then not enough power is being supplied to the board. 

This could be low  charge on battery, poor battery or bad connections from battery to battery sled connectors.....ect.

You should have no problem achieving 30 watts with correct power input. 

Edit: I'm assuming that Relay is off on above graph.

Link to comment
Share on other sites




I attach csv file, I checked the batteries with the testet they are charged (they have a week of life) and I ticked the volt box, it never drops below 3.7 volts.

I also cleaned the connector with alcohol and inside the card to make sure that everything is dry. If you set for example 16 watts, I get there in the graph for half a second, then it always stands at 10 watts on average, whatever power I set.

I also tried with another good quality atomizer always with ss316 at 0.25 ohm and it is the same thing, the box does not want to push more than 10 watts.

up to two days ago everything was fine, I thought about the liquid leaking from the atomizer, which went into the box, but I checked it well, everything is clean inside. maybe some sensor of the wet circuit?


what can I do?


I forgot to add that replay is logically disabled !!!!





Edited by Pino74
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...