Jump to content

DNA250C resistance issues


Recommended Posts

Hey lovely people, I have some resistance issues with several devices (paranormal and drone) showing the same problem. Long story short (will elaborate asap),  I have two paranormals and two drones that aren't reading cold and live ohms correctly. For example: They all read a RDA with two coils and say the cold ohms are 0.34 and when I fire, it drops to 0.28 and do the Temp Protect thing. Unless I manually change the live ohm, it will not read the ohms correctly. However, when I screw a tank on, it reads ohms near perfect.

I own one of both devices, Paranormal being the oldest and then there's my mate's Paranormal and a customer his Drone from my work that encountered the same issue. Both the other devices have never been changed or altered with settings or themes. Mine are customized. They all run latest servicepacks and everything works fine except the reading issues.

I have tried resets, did the proper deep cleaning on the outside only. Inside would be an option if there was a reason for it, but they all are obtained at different times and are used by three different people. All devices are, sofar I can tell, in mint condition. No major leakage from liquids or whatever. I even clean my 510s from the black electrical disacharge stuff, so I always have a clean connection.

I also tried different RDAs, coils and they all had multiple disassembled ultrasonic cleansings. Nothing changed =/ I thought it was just mine and didn't really bother, but now it's happening on other devices as well.

Atomizer Analyzer also never goes stable and always reading too high as I said above. Whether or not it goes stable, it is still too high compared to the live ohms.

Last but not least... When I take the RDAs to other not-so-smart chipped devices, they all read ohms correctly.


I don't know what else I need to share, but let me know if so. Thank you for reading!


Link to comment
Share on other sites

Thank you for replying.

Yes dry burned. Contact coils. Mostly fused claptons Ni80, but in general Ni80 and I tried Kanthal but it does the same.

The thing is that I've been doing this building for a while now and all of a sudden it does this and with both my Goon and Twisted Messes. I just cannot figure out why. Either I am overlooking something really stupid or somethings wrong somewhere and coming here is somewhat my last resort or atleast discuss the issue with more expierenced DNA users.


Link to comment
Share on other sites

Try spaced coils as they seem to be the coils of choice for DNA boards......contact coils can be tricky to use........  try this:

Build coils, dry burn if you choose.

Set the atty aside and let it get completely back to ambient temperature. The device should be at ambient temperature also for best results.

Attach atty to the device and vape.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...