Jump to content

HCigar 75c Replay suddenly no longer displays save puff

Recommended Posts

Hi, i have a number of both 250c and 75c devices and use them all with Replay with no problem. My Hcigar 75c i have happily used with Replay for some time then suddenly it's as if replay is idle and the box that would usually say "save puff" constantly stays blank. I have tried the device with escribe but that seems to suggest it is set-up as usual so it's a mystery. Any ideas?

Link to comment
Share on other sites

It suddenly after 4 hours started working again.

The coil is a SS316 3 core parallel, it wasn't actually a new coil i had simply dry burned it and changed the wicking and when i then went to use it on the HCigar it wouldn't allow me to save puff for the next about 4 hours. I have cleaned coils and re-wicked this way many times and it's never effected Replay before. During the period it wasn't working i did try the RTA on other devices and Replay worked fine just not the HCigar and then suddenly when i had given up all hope it started working as if nothing had ever happened.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...