Jump to content

Recommended Posts

I just got a therion dna75c squonk and it is reading resistance so wrong. My coils on ohms reader is 0.28 and the reading on my therion is .530. Why won't it read correctly and Everytime I lockt thenunlock device it asks if it's a new coil at this price there is no way this is normal my coils are taking forever to heat up like 3 to 4 seconds to get good vapor. Please help

Edited by Stevie23
Misspelling
Link to comment
Share on other sites

Usually in the helix menu you can manually change the resistance. If you are confident in the resistance of the spiral, then put the value that suits you. During thermal control, the resistance should be locked, it is desirable to lock the resistance in any mode.

Печать.jpg

Link to comment
Share on other sites

1 hour ago, dwcraig1 said:

If I were to guess I'd say the 510 ground connection is poor, for what ever reason.

Since it's new are you able to return it. If not open a ticket with Evolv and they will most likely take care of it for you.

https://helpdesk.evolvapor.com/index.php?a=add&category=1

I bought it used so idk if opening a ticket will be possible 

 

Link to comment
Share on other sites

14 hours ago, dwcraig1 said:

Give it a try, pretty sure it will work out.

I tried because I bought it used they won't fix it. You Kno where I can buy a lost vape bf replacement 510 connector? I tried to go-to their website but it doesn't work it's like they deleted it

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...