Jump to content

Ohms too high


elib
 Share

Recommended Posts

I have a w9tech Hercules atomizer that starts at 1.7 ohms and goes up to 3+ when heated up. It takes around 40 watts. I can't figure out settings to get my DNA200 DIY mods to not complain about Ohms too high. I've tried locking ohms, tried no TC, Watts mode etc. 

Any ideas how to get this to work? The company makes their own mods that will handle it but I have 3 dna200/alpinetech setups I built and I don't want to but another.

Thanks!

Link to comment
Share on other sites

That board has a 6 volt output voltage max with 2 cells, 9v limit with 3 cells.

2 cells -> ~22watts max at 1.7ohms, watts decreasing as the ohms rise. 3 cells ~47 watts max at 1.7.

'Ohms too high' is really just informational, and you can just turn the message off knowing you might be hitting the limits

Link to comment
Share on other sites

4 minutes ago, elib said:

Oh really it’s not cutting power?

 

18 minutes ago, Wayneo said:

watts decreasing as the ohms rise

Means 'yes'. Steam-engine ohms law.

The message is theme related, so look around in there.  

19 minutes ago, elib said:

How do I disable the message? 

Actually 'Screen' tab. Change it up there. I think 2 nd and 3rd option. Right after orientation. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...