Jump to content

ThinkVape Finder 250c cell 3 at 3.6v


AlMajed
 Share

Recommended Posts

Hello everyone,

I have Finder DNA 250c from ThinkVape, it has 3 batteries of 18650, it was working fine for about two months with no issue at all, it was the best experience that I have with vaping. However, before a month ago I start notice my battery never reach 100% while I'm sure its full (between 94%-98%)! I didn't mind that, and I continue vaping because it's not a big deal for me, but now the situation is different! My mod is 54%!! And when I charge it with escribe while monitoring it reach 76% after a long charge.

Something need to be mentioned, when I take the same batteries to Wesmic GEN3 it appear as full and I can vape it for the full day! Also on my finex charger it's 4.2v on each!

While monitoring with escribe it shows that cell 1 and 2 at 4.2v, but cell 3 is at 3.6v, I tried switching the position of batteries but it keeps saying cell 3 is 3.6v, also I tried different batteries with the same result.

I'm using LG HG2 3000mAh and AWT 3.7V 3000mAh

Any help please?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...