Jump to content

250c 3s lipo problems


Recommended Posts

I got a box of parts from a customer that "tried" to build his own dna250c having never done it before, just wanted to start there.  Ive got the 250c wired up but it is not reading the 3c turnigy graphene lipo he sent me with all the parts.  I have installed a 3s jst plug as shown for a 3s set up and bridged the 3&4 taps and this is all I am getting. (see image)  When I unbridge the 3&4 I show 0.178v on cell 2 & 3 but nothing on one.  I am lost I have built many 200 and 250 but this is my first 250c.  Im wondering if I have it right as well since this Graphene is wired with differnet colors than im used to (assuming red is the ground and 3 black are cells )



Link to comment
Share on other sites

  • 2 weeks later...

Have you tried checking voltage of the graphene cells individually with a multimeter? That would determine if the board is misreading voltage.

To me, it would appear that the LiPo is excessively discharged, or damaged in some other way. Try a different battery...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...