Jump to content

DNA 75C: Incorrect indication of the battery charge level.


tramog
 Share

Recommended Posts

Nothing serious ... but on my box with DNA 75C known that the battery charge level stops at 98-99%, never ever 100%. It also happens to me if I insert batteries previously charged with an external battery charger. Performed the "battery test" for both batteries (Samsung 25R and Sony VTC5A) ... nothing, the boxes signal me to charge battery (green led) and 98% charge level. Does it happen to you too?

  • Like 1
Link to comment
Share on other sites

Hi,

same issue for me on a mirage (lost vape) with ijoy 20700 batteries (the 5 legged ones).

when freshly charged using a nitecore D4, I am getting a 97% charge indicator on the mod, and when charged via usb, the battery indicator never reaches 100%.

I’m interested in a fix for that too !

 

 

Link to comment
Share on other sites

The above post is correct  hook your 75c BF up to EScribe  then go to MOD then go to battery and change the voltage on the graph that's at 100%. Mine was at 4.20v and I changed it to 4.19V. Your problem solved. Look all the way to the left 4.19v. After you make the change Upload Setting To Device.

 

Snap16.thumb.jpg.86cf9c272ae3ccdd259dd778ee644f1d.jpg

 

 

 

  • Thanks 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...