Jump to content

USB Not Recognized

Recommended Posts

Hi all, i have problem after updating the lastest escribe software n firmware... My PC says "usb not recognized" It is charging, but cannot detected on my pc Mod Works normal... I tried to uninstall n install again, but not going better I try to switch usb port, but it didnt solve the problem Changing my usb cable, it still the same Anyone can help? Thanks

Link to comment
Share on other sites

  • 2 weeks later...

I'm having the same problem with 2 different mods and I have tried 4 different cables including the cables that came with my mods. I have tried rebooting my mods and even hooking them up with no batteries in the and still keep getting the same message. I am using version 1.0.42

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...