Jump to content

screen flash during fire button press


Recommended Posts

Can someone please tell me what it means when the board wont turno on, it only goes to the intro dna screen when i hold the fire button down. If I continue to hold the fire buttton the wattage screen comes up and then it says check battery. I tried it with ten different batteries. I'm assuming theres a bad soldier joint but I jsut resoldiered all the connections.



Link to comment
Share on other sites

Well, I ran thru all the wires, resoldiered all the connections, and ran thru the settings in escribe and it had changes from 2 cells to 3 cells. This is what happens if your trying to run  the board on two cells and its programed to be running on three. Maybe this will help someone as lame as me someday..

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...