Jump to content

Anarchist Solara Lipo 1200Mah


Lo_ohms_
 Share

Recommended Posts

So I just got an anarchist DNA 200 to add to my collection. It's my first Lipo, I don't know if my standards were just really high or I have a janky battery. Fully charged it doesn't even last half a day, not chain vaping, not a super low build on it, and vaping about 80-90w. Everytime I take a vape the battery percentage drops at least 1% if not 2. I also get really bad hot button if I use a build under .2ohms. It gets like a mech hot button that you can't even press it. Anyone have any ideas of what could be happening? I bought it new from a local shop and it didn't have the warranty card, owners booklet, or authenticity card. I'm thinking it may have been returned and they put it back on the shelf

Link to comment
Share on other sites

Take it back to them.... for one thing current doesn't flow thru the DNA board mounted fire button like a mech mod so you shouldn't be getting a hot button.  Something is going on with your device if you get a really bad hot button. Surely they didn't wire a line switch between the battery and the board??????

If you are vaping 80/90 watts then I think the battery longevity is about right. Since you just got it just have them replace it or refund.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...