Jump to content

Help please


Bryce1992
 Share

Recommended Posts

Got my DNA200 Duo worked great. Took out the lipo. and let it charge overnight. it worked this morning but like a hour ago it just stopped working. No button works. Screen/mod won't turn on. Connected it to my PC. The mod turns on. Checked device monitor. Battery registers just fine. Voltage of the battery pack is what it should be. individual cells are balanced and USB is charging it. so the battery is fine. The mod registers the correct values for it. I checked the battery fuse on the board. that is fine too. But the moment I dare to unplug the USB the entire system just shuts down. I noticed that the chip won't register my atty anymore. just a question mark. Checked the connection to the board and those seems to be fine. exactly the way they were in the beginning. Tried downgrading and upgrading the firmware but it doesn't do anything either. I am honestly stumped. the battery connection is solid. the atty connection seems solid. The only thing that seems to have gone iffy is one lead of the fire button on the PCB. It kinda wobbles but it's pretty solid and can't touch any other leads. Even then at most that would cause a false button register. any idea what is going on?

Link to comment
Share on other sites

to add......in escribe, under the "mod" tab make sure "3 cell" is still selected and uploaded to your mod. just to point out, the dna 200 balance charger works just fine. no need to pull the lipo out and charge it on a separate charger. if you're leaving it to charge over night anyways, might as well leave it in the mod to charge. how abouta screenshot of DM with all of the battery options ticked.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...