Jump to content

Mod not detecting atomizer, desperate for fix


Recommended Posts

Hi, I recently had a catastrophic failure of a DNA200 device and am waiting for that issue to be resolved, so in the interim, I bought myself cheap DNA75 mod (HCigar VT75 Nano), about a month ago. This was a large mistake as the mod broke down very quickly (hinge that holds battery screw plate snapped right off, threads stripped) but the mod still worked fine it was just tricky to change batteries. So, fast forward to a week later and all of the sudden I screw in an atomizer, and the display is showing 0.00 ohms. I pressed the fire button several times, and each time I see the voltage go up to 0.01V for half a second, then the wattage goes down to 0.00W on the display, and it stays in that state for about 1.5 seconds, after which, the screen flashes "check atomizer". I tested 6 different atomizers, all with proper electrical connections, some even with adjustable 510 pins which I made stick out farther just in case. I experienced the EXACT same error each time with each different atomizer so I ruled that out, especially since my old SMOK X CUBE II detected the atomizers properly (thought of that later). So I decided to disassemble the device and clean out with 99% isopropyl alcohol (rubbing alcohol) of course excluding the board, which I just wiped down with an anti static cleaning rag. I made sure to clean out any e-juice from EVERY nook and cranny. I then reassembled the device (by the way, the internals of the mod were fine, nothing broken there) and tested it only to see the exact same error, ugh. So I'm in a panic cause now both my DNA devices are broken and Evolv refuses to communicate with me on my DNA 200 issue, which almost burned my house down, but I want to focus on the DNA75 right now cause I'm pretty sure the board is dead. I didn't know the proper forum to put this in, so I apologise if it is in the wrong one. Any help fixing this would be GREATLY appreciated. Thank you so much for taking the time to read my long post!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...