Jump to content

DNA75 TC Issues - Patience waning!

Recommended Posts

Hopefully someone can help me as im loosing patience with my DNA devices and have no issues with the same build on a EVIC Mini.

I have an SDNA75 and a Therion DNA75 and for the past three weeks TC has been either poor or not working.

My main atomiser is a Sapor RTA dual coil @ 0.43 OHMS with SS316L.  I have rebuilt this multiple times, and tried multiple profiles.

The symptoms are as follows:

The vape is way too hot and temperature way off
When firing in TC the screen goes straight from the set temperature to "OFF"
The vape is anaemic.

As noted earlier the exact same atomiser and build works flawlessly on the Evic....

I have tried:
Resetting the device with the profile backup straight out the box
Multiple material curves including steamengine and Jaquith_V7SS316.csv

I would appreciate any help you can offer

Link to comment
Share on other sites

welcome to forum SillyBilly. let's see if we can't get your mods vaping right......

when the display goes from your set temp to "off". that means you've been kicked out of TC and dumped into regular wattage mode. most likely do to - a loose connection somewhere between the 510 and your build, not high enough of a set wattage, wrong material CSV, incorrect base resistance reading (usually too high of a reading if it kicks you out of TC).

i would make sure you're using the correct material CSV, check your mods "internal resistance" setting (what is your "mod resistance" set to for both mods?) and look at your preheat settings.

what would also help is if you are able to post a screenshot of device monitor while firing the mod or mods with the build that won't work for you. device monitor is a handy tool for diagnosing troublesome builds.

Link to comment
Share on other sites

I have experienced some more strange behaviour from the mod, this time building with SS430 on a brand new Sapor RTA and would appreciate some guidance.

  • My device has the latest service pack
  • Im using the SS430 DNA profile from Steam Engine
  • All connections are tight
  • The battery is a Samsung 30Q.

The issue is as follows:

  • Insert battery, device works fine as does TC with SS430
  • Device goes to sleep
  • Wake up device and the vape is incredibly weak, removing and reinserting the battery brings it back to its former glory.

Has anyone experienced this issue?

Edit: after further testing, its not specific to the wire type but the device itself and the issue has manifested using SS316L also.
  • Thanks 1
Link to comment
Share on other sites

you're experiencing "refinement". it's the board refining the base resistance lower when the device is idle or goes to sleep. this is normal. refinement makes the device more accurate when in TC mode. all you have to do is increase your temp setting to where it was vaping before refinement. EX - if it was vaping great at 420F at first, then the device went to sleep and the resistance refined and now the vape is weak, you would have to increase the temp up, 450F+ (estimate)

  • Sad 1
Link to comment
Share on other sites

You can also go to Mod tab in eScribe and check if the manufacturer has set up your device. Some manufacturers don't provide this essential data for their products (shame on them). For example, HCigar didn't provide data for my T75's resistance and thermal properties. If that's the case with your mod, test its internal resistance (or find some reliable data online - for example 0.0045 ohm worked for my VT75, but measuring the mod's internal resistance with a copper rod or - better - a copper threaded plug inserted into the 510 connector will give you more accurate data). Also, when you can leave the mod connected to your PC for a few hours, run "Case analyzer" (you'll find it in the Mod tab in eScribe) and then let the tool use the collected data. By doing this you'll help the device better calculate the actual temperature of the coil.

PS. It's my first post on this forum, so HELLO EVERYBODY. :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...