Llittle_Llama

Members
  • Content Count

    15
  • Joined

  • Last visited

Community Reputation

2 Neutral

About Llittle_Llama

  • Rank
    Member
  • Birthday 03/24/1982

Personal Information

  • What DNA product do you own or plan to buy?
    DNA 250

Recent Profile Visitors

80 profile views
  1. I bought a DNA mod about a year ago from a guy I used to be friends with. I bought it about a week after he got it along with a titanium Goon (wanted the Goon and had to buy them both) and didn't really use the mod much because I have so many others to play with. Finally got around to trying it out and it lasted about a week sadly. Well I found this forum and with the (tremendous) help of dwcraig1 was able to get it fixed! Well it came in today from being fixed by Evolv (straight best CS EVER!!!) and I opened it up and the chip wasn't glued in or however it's supposed to be affixed so the buttons fell out. I sat it on the shelf (didn't even try to find the buttons (depression is a bitch) and went and laid down out of frustration. Well my wife came home at 9:30 tonight and saw it and wanted to know why I wasn't using it and I told her about the buttons and whatnot. I finally put it back together (took all of 15 seconds to find and put together) and tossed the lipo in. DAMN! I forgot how amazing this thing is!!! So I've been using it the last few hours and I love the damn thing more than any other mod I've ever had, and just like most of you I've had (have) dozens. Now here's my issue: 1. I don't like this box, I originally bought it to get the titanium Goon but soon learned the magic that is Evolv. 2. I want something plain, and this box is nothing but an attention getter. 3. As awesome as the lipo is, I have about 20 each of 18650/27700s and prefer them. 4. I want something that's "mine" that I've decided on. So is my mod actually worth anything, or is it just another basic mod? If it's not worth anything should I just remove the chip and put it in a new enclosure, or sell it cheap and buy a new chip/mod? Lastly, is there a difference between the DNA250 and DNA250 color besides the screens? I would rather have the "fun" of the color in my next one if there's no other difference. Lastly, how to I get the chip to stay in the box? I don't want to just put a drop of super glue on it since that seems haggard as hell, but I also don't want it being help in there just by the battery holding it in place.
  2. Llittle_Llama

    Need help with a dead 250

    So GREAT news! I got my mod back yesterday from Evolv and it now works! Shout out to Evolv Customer Service, it makes what I'm about to ask more understandable: I'm not super happy with the way the lipo sits in the box. It either rattles just a tiny bit or it pushes against the door. It's very slight but enough for me to hate it and not want to use it when I have literally 50 other mods. Is this box/mod actually worth what it sells for? Could I sell this box and keep the chip, or would I need to sell it whole? After how things went with fixing this I really really want to have 1-2 DNA mods to switch back and fourth between. I want to try my hand at "making" one, but a normal pre-made box would be nice as well. I would like to get rid of this one to supplement buying the other 2, but don't know if it's worth it or not. I'll probably order a chip today or tomorrow and a box kit so I can "replace" this one for now. I'll definitely want to keep this one until I have a nice DNA to use :)
  3. Llittle_Llama

    Need help with a dead 250

    Aaaaaaaaaaaaand mailed out yesterday!
  4. Llittle_Llama

    Need help with a dead 250

    Aaaaaaaaaaaand ticket submitted :D
  5. Llittle_Llama

    Need help with a dead 250

    First battery: Cell 1: 2.12 Cell 2: 3.35 Cell 3: 3.90 New battery: Cell 1: 2.15 Cell 2: 3.29 Cell 3: 3.95 Seems a little suspicious to me...
  6. Llittle_Llama

    Need help with a dead 250

    So new battery came in today... I'm having the exact same issues! Battery levels are exactly the same as before with this battery. No idea what to do at this point since I don't think both batteries could be so close to the same levels. Here is the pic for the new one:
  7. Llittle_Llama

    Need help with a dead 250

    Ok, I think it's working. Nothing is showing differently on the device monitor, but when I try to do anything else with it I'm told that the device is in use. I did download the newest update for it though so that's a thing I guess.
  8. Llittle_Llama

    Need help with a dead 250

    Good lord, I had no idea that the thing above "Device Monitor" was clickable! I'm in it now, will post back in a few
  9. Llittle_Llama

    Need help with a dead 250

    This is really frustrating trying to both fix something and learn a new software at the same time. It has to be even worse for you since you're trying to do the same thing as me but online and not in your hands. I really appreciate the help, and honestly feel like I'm almost there! If I had that Tools tab I think I would be good by now 😕
  10. Llittle_Llama

    Need help with a dead 250

    Mine looks nothing like that, the only things I have are this:
  11. Llittle_Llama

    Need help with a dead 250

    These are my only options, and when I try any of the ones at the top dropdown it just wants me to set up parameters.
  12. Llittle_Llama

    Need help with a dead 250

    I can't delete this post, or one of the pics on the post I made earlier 😕
  13. Llittle_Llama

    Need help with a dead 250

    I've never used escribe before, so it's all new to me. The battery is showing not charged, but nothing happens when I plug it in to charge it. It won't come on, and the screen stays blank. Can it be turned on when charging, I would assume so but I feel I need to ask. The mods acts fine when plugged into my Macbook with the exception of the screen being dark. Also, the screen has become super dim since this started happening. When I hit the "Fire" button on escribe the screen says "Check Battery" Ok, this is what I ended up with:
  14. Llittle_Llama

    Need help with a dead 250

    I’ll definitely message them, but here’s the rest of the info on the mod:
  15. Llittle_Llama

    Need help with a dead 250

    I bought a custom mod about a year ago. It worked perfectly until one day it just wouldn't turn on. I bought another battery (lipo) for it and nothing changed. I know its a real chip, I got the COA with it and it came from a reputable maker (I'll get the name later tonight). I emailed them and they were of no help (so maybe not that great of a maker?). Is there someone that could help me, I can't solder to save my life and I've never messed with a chip/lipo before. ANY help would be greatly appreciated as I want to use this awesome mod again! I am a hobbyist on a budget and this was by far the most expensive mod I've ever bought. Thanks in advance!