Jump to content

No Atomiser issue


kalagan
 Share

Recommended Posts

Hello, 

 

I know, I know, it's probably a regular topic but I just can't find the solution despite having a look around. I've  got a Paranormal 250C and after changing the coil as usual, I get this message now.

The solution seems to clean the coil under it and clean on the connection on the mod but even after doing this I still get that message. I've put the coil on a different mod and I also get this message. Same result when I try another brand new coil. 

 

Any suggestion? 

Thanks so much

 

Link to comment
Share on other sites

I assumed that the issue was coming from the atomizer (a freemax pro mesh) because it doesn't work on a different mod but actually when I put a tank that works fine on the DNA mod I now get Check Atomizer message ... humm 😭

I've never had so many issues with a mod than this Paranormal Mod .. driving me mad

 

Any advice will be much appreciated!

Link to comment
Share on other sites

Right so I've checked the pin, if I press on it it does goes down a bit and back up but I’m not sure how smooth that should be. It feels quite stiff but there is some movement possible up and down.

Do you mean I should unscrew the screws around it as well to do this? I basically used tweezer to wiggle it and pull it up.

Thinking of it, last month if I screwed my tank very tight I would get the Check Atomizer message .. maybe it’s just too low now and won’t spring back up correctly.

No idea how to fix that though

Edited by kalagan
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...