Jump to content

Slow charge past ~70% on Lost Vape Paranormal 250C


luca87
 Share

Recommended Posts

Hello everybody! 

I just got my first DNA mod, a Lost Vape Paranormal 250C, which I'm loving so far. However, the mod is very slow in charging the batteries, taking like half an hour to gain a 1% after 70% of total charge.

I'm running the mod with two brand new VTC5 (same seller as the Paranormal, Element Vape), which already appeared to be about ~70% charge in them (don't have a standalone charger right now). 

It seems like the mod tries to ramp up the charging current (up to about 0.5-0.8A), only to stop in about 1 second (and "Charging" mode disappears from the Device Monitor bottom status bar), wait another second or so and then repeat from the beginning. I tried using different computers as well as 2A wall chargers and several different USB cables, the results appear to be the same. To give you an idea, over a period of about 7-8 hours the last night, the mod was only able to charge the batteries from about 75% to 93%. 

You can find a sample recording attached. I'm running the latest international firmware (also tried the US one, as well as several hard reboots of the mod).

Is this normal behavior, given the current charge of the batteries? I did not have time so far to discharge the batteries and try when they are almost empty. Also, the two batteries were already pretty balanced upon receiving them.

I apologize if I'm not seeing something obvious here or if I'm accidentally infringing any forum rule, this is my first post.

Thank you!!

Luca

 

1177685776_2018-11-0110_41_46-DeviceMonitor-EvolvDNA250Color.thumb.png.ccaf3b0565ad1ee3dcb4969c0c14cc55.png

Link to comment
Share on other sites

  • 2 months later...
1 minute ago, acultabovetherest said:

im having this exact issue with my dna250c 2x  2x700 rebel squonker. it charges in .5 pulses. my other dna250c doesnt have this issue, and settings all look mostly identical.

 

any help please?

Hello! In the end, I resorted to contact Evolv' customer service, which was SUPER helpful, and immediately proceeded to RMA the entire vape and send it back after a lightning fast repair. 

Now it works perfectly, it was indeed a hardware problem. I advise you to contact the customer service, which is absolutely stellar in my experience, and if you can, make sure to attach a screenshot of the charging pattern through Escribe's Device Monitor.

Good luck!!

Luca

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...